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Mastering master pages: part 1 of 2
FrameMaker’s master pages enable you to control the layout of your 
document’s pages — and more. Steve Rickaby looks at the options.

Tools

Even if you are a novice user of FrameMaker, you 
will have used master pages, although you may 
not have realised it. FrameMaker uses master 
pages to control the page layout of every page of 
a document or book.

Jane Dards touched on master pages in 
the context of side-heads in her article ‘A 
Bit on the Side’ in the Summer 2005 issue of 
Communicator. This, the first of two articles, 
gives a general overview of master pages and 

their various options, then describes how they 
can be applied automatically. The second article 
will consider some slightly more exciting ways 
of using master pages.

Some aspects of master pages can seem 
complex and confusing, but correctly applied, they 
can make your work with FrameMaker a lot more 
productive and enjoyable. As a simple example, 
it is easy to make FrameMaker format the first 
page of each chapter of a book differently.

Two types of document
One way of looking at the use of master pages is 
mentally to divide documents into two broad groups:
	Book- or report-style publications, in which 

most pages follow similar layouts.
	Newsletter- or magazine-style publications, in 

which many (or all) pages have different layouts.
These two document groups have very different 
layout requirements, irrespective of how they 
are ultimately delivered to their consumers. 
FrameMaker caters for both.

Displaying and working on master pages
When you create a new document by selecting 
File>New Document, FrameMaker opens a 
dialog that enables you to:
	Choose from a number of templates.
	Create a blank document by clicking on one of 

the Use Blank Paper buttons. 
If you click on Custom, FrameMaker displays the 
Custom Blank Paper dialog, shown in Figure 1. This 
enables you to choose a page size, margins, number 
of columns, and single or double-sided pagination. 
Your document’s master pages, and the objects 
FrameMaker places on them by default, depend on 
the choices you make in this dialog. For example, 
selecting Double-Sided creates a blank document 
with two master pages, Left and Right, which have 
mirrored inner and outer margin layouts.

FrameMaker applies default master pages 
to every body page automatically unless you 
override it. With a document open, selecting 
View>Master Pages displays a master page: the 
master page displayed will be that applied to 
the body page displayed before you switched to 
master page view. You should see something like 
Figure 2 (which has been truncated). There are a 
couple of things to notice about the master page:
	The view’s bottom border says ‘Right (2 of 

2)’, indicating that you are viewing the Right 
master page. (The other, obviously, is the Left 
master page.)

	FrameMaker has created three text frames on 
the page: a header frame, a main text frame, 
and a footer frame.

Figure 2. Master page view (truncated)

Figure 1. The Custom Blank Paper dialog
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You view and work on FrameMaker master 
pages in the same way as you do body pages. 
For example, you can draw or place graphical 
objects on a master page, and they will then 
appear on any body page that uses that master 
page. However, there’s an important difference 
between master pages and body pages: if you 
use the text frame tool to draw a frame on a 
master page, FrameMaker will ask you what the 
frame is for, displaying the Add New Text Frame 
dialog (Figure 3). To understand how this works, 
we need to look at the different ways in which 
FrameMaker uses master page text frames.

Two types of master page frame
Text frames on master pages are of two types: 
background text and tagged flows. FrameMaker 
handles these very differently. As Figure 3 shows, 
tagged flows are identified by alphabetical flow 
tags. A helpful way of thinking about flows is 
to think of them as stories: if, for example, you 
are laying out a newsletter, you might wish to 
continue a front-page story on an inner page. 
A separate flow enables you to do this. For 
documents such as reports, books, manuals, 
and so on, you would normally use only one 
flow. You can tell tagged and untagged flows 
apart by selecting them and then selecting 
Graphics>Object Properties to display the 
Customize Text Frame dialog — a tagged flow 
will have a flow tag, while a text frame used for 
background text will not. (To select a background 
frame, you must be displaying master pages.)

The Customize Text Frame dialog is also 
where the text flow can be set to display 
multiple columns — don’t be tempted to create 
separate text frames on the master pages for 
this. FrameMaker can also be asked to balance 
columns to equalise the amount of white space 
on partial pages.

In Figure 2, the header and footer frames are 
untagged, while the main text frame has the 
flow tag A by default (although you can give a 
flow any name you want). When you are working 

on body pages, FrameMaker displays the flow 
tag at the bottom-left of the document window.

To create a new master page, select Special>Add 
Master Page while displaying master pages. The 
Add Master Page dialog offers you the option of 
creating an empty master page (one with no text 
frames), or a copy of an existing master page. You 
can then edit the new master page as required.

How FrameMaker uses master pages
The simplest case is a single-sided document 
with one master page, which FrameMaker calls 
(perhaps a little confusingly) Right by default. 
The main text frame will have a flow tag A and 
the Autoconnect property — about which more 
below — will be on.

As you add text to the first body page, 
FrameMaker places it in the main text flow 
(frame) until the end of the frame is reached. 
When you add more text or graphics, referred to 
as ‘overmatter’, FrameMaker creates a new page 
and frame to accommodate them. 

This ‘word processor-ish’ behaviour is what 
is normally required in books, manuals, reports 
and so on, and seems natural. However, if you 
are working using custom page layouts, for 
example in a magazine layout in which each 
page is different, overmatter is a potential 
problem. You don’t want a new page to be 
created automatically: overmatter might be 
relegated to a distant page later in the magazine 
or newsletter, or might need to be cut entirely.

You can prevent FrameMaker adding 
new pages to accommodate overmatter by 
disabling the Autoconnect property for the 
main text flow(s) on the master page(s), then 
reapplying the master pages. FrameMaker 
will then indicate the presence of overmatter 
by displaying the bottom border of the main 
text flow as a solid line, and will not create 
new pages for it. FrameMaker provides several 
commands for manually linking text flows under 
Format>Customize Layout.

In a more complex situation, for example in 
which master pages contain multiple text flows, 
some of which have Autoconnect on and some 
of which do not, the Autoconnect flag is always 
honoured — pages and frames will not be created 
to accommodate overmatter if Autoconnect is 
off for the flow, even if additional pages already 
exist that contain frames belonging to that flow.

Adding objects to headers and footers
Although you can create as many master pages 
as you like, this does not mean that you have to 
have a different master page for each different 
header and footer. FrameMaker’s running 
header/footer variables enable you to add 
header or footer text that is based on objects on 
the body pages. For example, if you are writing 
a user guide in which each chapter is divided 
into sections that are titled using a paragraph 
tag A-head, defining the Running H/F 1 variable 

Figure 3. Add New Text Frame dialog
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as <$paratext[A-head]> and placing it in the 
header of the Right master page will cause the 
current major section heading to appear on all 
subsequent right-hand body pages.

Page numbers are catered for by FrameMaker’s 
predefined variable <$curpagenum>, while 
other variables cover things like the page count, 
the current date, the date the document was 
created, and the date it was last modified.

Applying master pages automatically
Let’s assume that by this stage you have a 
double-sided document with three master pages: 
the default Left page, the default Right page, 
and a special one called First, to be used on 
the first page, for example in each chapter of a 
book. This is probably one of the commonest 
uses for custom master pages.

In a double-sided document FrameMaker 
alternately applies the Left and Right master 
pages by default: if your document starts on a 
right-hand page, FrameMaker applies the Right 
master page to it automatically. How then can 
you apply the First master page?

You could, of course, display the first page 
and apply the First master page to it manually, 
using Format>Master Page Layout>Master Page 
Usage. However, it is possible to automate this 
process, because from Version 7.0, FrameMaker 
enables you to associate a master page with 
the presence of a paragraph tag (or element, in 
structured FrameMaker) on a body page. 

This is done using a special flow on the refer-
ence pages, Master Page Maps, which contains 
a mapping table: UnstructMasterPageMaps 
for unstructured FrameMaker documents, and 
StructMasterPageMaps for structured documents. 
These tables do not exist until you select the 
Format>Page Layout>Apply Master Pages 
command for the first time in a document. 

The master page mapping table for 
unstructured documents contains four columns:
	The paragraph tag name
	The right-hand master page to use
	The left-hand master page to use
	A range indicator, described below
	A comments field, where you can describe 

the purpose of the automatic master page 
application (very useful later!).

The range indicator has three possible values:
	Single (or blank) applies the named left- or 

right-hand master page only to the body page 
that contains the named paragraph tag.

	Span pages applies the left and right-hand 
master pages to the body page range from 
the first to the last occurrence of the named 
paragraph tag.

	Until changed applies the named left and 
right-hand master pages until either a further 
master page mapping is triggered, or the end 
of the document is reached.

So, in the example of our First master page for 
a book chapter, we could create a paragraph tag 

ChapHeading to format the chapter heading, 
and an entry in the UnstructMasterPageMaps 
table as follows:
	Paragraph tag name: ChapHeading 
	Right-hand master page: First
	Left-hand master page: (blank)
	Range indicator: Single.
When you then select Format>Page Layout> 
Apply Master Pages, FrameMaker will apply the 
First master page to any right-hand body page 
that contains a paragraph of type ChapHeading, 
and only to those pages.

Adding static page objects
Master pages are also used for adding page 
decorations, such as graphics that appear in the 
same place on each page on which they are used, 
or coloured page backgrounds.

With a master page displayed, you can select 
File>Import>File to import a graphic directly 
onto a master page. FrameMaker places the 
graphic centrally on the page. This not always 
terribly helpful, as it is likely to land behind the 
main flow frame, making the graphic unselectable 
unless you apply Graphics>Send to Back to 
the main flow frame. The simplest way around 
this is to draw a graphic frame on the master 
page using the graphics frame tool on the Tools 
palette, then import the graphic into that.

One thing that’s worth remembering, which 
can cause some confusion, is that objects placed 
in tagged flows on master pages do not appear 
on body pages: to display a background object 
on a body page, you need to place it in an 
untagged flow or graphic frame.

Dynamic objects on master pages
By now you could be forgiven for thinking that 
master pages are a little dry and dusty: 
necessary, but not particularly exciting. 
However, with a little cunning, it’s possible to 
place dynamic objects on master pages. By 
‘dynamic’, I mean objects on a master page that 
can be made to move and/or display differently 
on body pages, under the control of features 
such as autonumber threads, paragraph formats, 
markers and so on. We will look at how this can 
be done in the next article in this series. C

For more information
Most of the FrameMaker features described 
in this article are covered in the FrameMaker 
User Guide and on-line help. You can find full 
details of master page mapping in the user 
guide. The FrameUsers site and mail list are also 
recommended resources: www.frameusers.com.
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