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Template Pack 5: Layout and Online

This collection of 11 templates boldly takes FrameMaker to places 
you probably never expected it to go. FrameMaker is justly 
renowned for its strengths in formatting long documents, where 
page after page displays the same general structure. That modus 
operandi doesn’t translate well to the mercurial world of ads and 
newsletters, where each page presents a unique face to the reader, 
and where sameness quickly builds to monotony. The Newsletter 
template, accordingly, takes FrameMaker on a wild ride into the 
realm of by-the-seat-of-your-pants layout design techniques.

Similarly, most users simply want to save a single document in 
HTML for online use at an already created Web site, but we took 
FrameMaker one crazy, stumbling step further. We use it as a tool 
for creating and maintaining an entire Web site from the get-go.

In short, this collection shows FrameMaker as you’ve never seen it 
before. The collection includes the following:

N Grids: A faint grid on the master page of each of these five tem-
plates (Grid2.fm, Grid3.fm, Grid4.fm, Grid5.fm, and 
Grid7.fm) serves as a layout guide for producing design-inten-
sive single page documents.

N Newsletter: Based on one of the Grid templates, these two tem-
plates both produce a four-page, double-sided newsletter with a 
fold size of 8.5 x 11 inches. News2.fm is a somewhat more com-
plex version of News1.fm.

N Web sites: These three templates let you create a personal Web 
site (Website.fm), a company Web site (Corpsite.fm), and an 
employee directory (Direct.fm) for use on a company intranet.

N Classif.fm: This template makes creating a classified ad page 
easy and quick. Incorporate it into other documents.
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Grids (Grid2.fm–Grid5.fm, Grid7.fm)

These five templates are not about formats, variables, cross-refer-
ences, tables, book files, or any of the other long document features 
and capabilities of which FrameMaker users boast and make use. 
Each of the files presents a standard grid commonly used in desk-
top publishing and traditional typesetting: two-column, three-col-
umn, four-column, five-column, and seven-column. These layouts 
let you use the techniques exploited in the Newsletter templates to 
use FrameMaker in a design-intensive way that will seem inherently 
wrong to most Framers, but which is optimal when dealing with 
single-page ads or publications such as newsletters whose layout 
from page to page is about as predictable as the weather.

Using grids
for design

Grids provide a graphical guide to laying out pages whose layout 
varies, sometimes dramatically, from page to page. You can base 
such documents on one of these standard grid templates, using the 
grids and guidelines to create text columns, position graphic ele-
ments, and so on. The techniques for doing this are fully discussed 
in the entry “Newsletter (News1.fm, News2.fm)” on page 4.
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Nuts & bolts

The grids themselves reside on the one master page of each tem-
plate. When you open one of these templates, the grid will be visi-
ble. Also notice the guide lines in the top and left margins. These 
guides are located on the body page and you can drag them around 
as tools to finesse your layout endeavors.

M To drag a copy of a guideline and leave the original in its current location, Alt-drag (Windows) or 
Command-Control-drag (Macintosh) or Control-drag (Unix) the guide line.

A special faint color called GridColor has been defined and applied 
to the grid and guidelines.

M To hide the grid and guide lines so they are not visible and do not print, press Esc v 6. To make the 
grid and guidelines visible again, press Esc v 1.

Turn on Graphics > Snap to ensure that any text or other frames 
you draw snap to the grid layout.

That’s really all there is to these five templates. We haven’t created 
formats because the types of documents you’ll create with these 
grids vary dramatically in the kinds of formats they’ll need.

Making it your own

The current definition for GridColor may be too faint on monitors 
set to thousands or millions of colors. If that’s the case, do this:

1 Choose View > Color > Definitions.

2 Select GridColor from the pop-up menu to the right of the 
Name text box.

3 Drag the sliders to define a new color.

4 Click the Change button and then the Done button.

t We defined GridColor in terms of the CMYK model, but since the 
grids and guide lines are never meant to be printed, it hardly matters 
which model you use.

To change the grid itself, choose View > Master Pages, make the 
changes there, and then save the template under a new name.
Template Pack 5: Layout and Online 3



Newsletter (News1.fm, News2.fm)

These two templates demonstrate a couple of new approaches to 
handling complex layouts such as newsletters or advertisements. 
Essentially these approaches throw many FrameMaker conventions 
out the window and rely instead on manually linked text frames 
drawn out directly on the body page.

Turn
FrameMaker
on its head!

The newsletter that is part of FrameMaker’s standard templates 
produces a simple document with an unvarying three-column for-
mat on every page. Many newsletter designers do not want to be 
restricted to that type of regularity. Rather than try to force a news-
letter into FrameMaker’s mold, we decided to turn the tables and 
try a different approach. We forced FrameMaker to do a newsletter 
the newsletter way. FrameMaker is no PageMaker, but used prop-
erly it can work as an occasional design layout tool when your 
needs are limited.

Nuts & bolts

Take a look at the master page in either of the newsletter templates. 
You’ll note a rather startling feature: there is no text flow. The usual 
master page elements have flown the coop. Instead the master page 
displays the three-column layout grid described earlier. Now go 
back to the body pages and take a look at how we laid out the sto-
ries. Each story is composed of text frames drawn out with the Text 
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Frame tool (using the grid as a guide) and then manually con-
nected with the Format > Customize Text Layout > Connect Text 
Frames command. Approaching layout in this way does mean that 
you cannot use standard FrameMaker features such as straddled 
paragraphs. But that’s the whole point of this technique. It’s quick, 
simple, and flexible—and better suited to normal newsletter layout 
than FrameMaker methods.

t When you switch from master pages back to body pages in a doc-
ument constructed like these newsletters, an alert dialog about over-
rides appears. Don’t worry. Keep the overrides and click Continue.

News1.fm. This template uses text lines to create the headlines 
rather than text in a text frame. That presents some disadvantages 
(for example, you can’t use paragraph formats), but when all you 
want to do is dummy a layout or produce a document on the fly for 
in-house use, this technique works admirably. The table of contents 
on the first page must be manually filled and does not automati-
cally update when you shift stories around.

News2.fm. This template is a somewhat more sophisticated varia-
tion on a theme. It does use formats for headlines, although you 
must place the headlines in their own unconnected text frame to 
make them straddle columns. The newsletter’s smarter table of 
contents uses cross-references.

The unusual techniques used to create these newsletters will likely 
catch FrameMaker purists off-guard, but we do find this approach 
less constrictive. It’s sometimes able to produce livelier documents 
than the structured lockstep that FrameMaker usually imposes.

Like any design-intensive document, these newsletters do not 
transfer to HTML well. For online use, stick to PDF.

Making it your own

The main element in our newsletter technique is to sketch the lay-
out on the page with text frames. It’s important, therefore, to mas-
ter connecting text frames—a skill and menu command many 
Framers simply don’t know. Here’s how to do it.

1 Use the Text Frame tool to draw a story’s columns on the page.
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2 Now select the first column and the second one (or in whatever 
order you want the story to flow). Choose Format > Customize 
Page Layout > Connect Text Frames.

3 Now select the third frame and choose the Format > Customize 
Page Layout > Connect Text Frames command again.

4 Continue doing this until all the story’s frames are connected.

5 Now choose File > Import > File and import the text (or type it 
manually in the story’s first frame yourself).

If you want, you can even name the connected text frames or flow.

1 Select one of the connected text frames and choose Graphics > 
Object Properties.

2 Enter a name such as “Story1” in the Tag text box. 

You can also connect frames on different pages so stories can jump 
across pages.

In News1.fm you can copy and paste the First Level and Second 
Level text lines to create new headlines for other stories and still 
keep the same look for headlines at the same level—basically a low-
tech approach to formats.

Bring in your own artwork for the masthead and illustrations. To 
add additional pages, you must use the Special > Add Disconnected 
Pages command, since there is no automatic text flow across pages.
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Web sites (Website.fm, Corpsite.fm, Direct.fm)

These three templates produce a variety of documents for online 
use as HTML. Website.fm creates a personal Web site. Corpsite.fm 
produces a Web site for a small business. Direct.fm lets non-Web 
staff maintain a company directory that can be used by your online 
staff in HTML form.

Framing a
Web site

In keeping with the cheeky spirit of this collection, two of the three 
templates in the Website folder do more than simply export well to 
HTML for use in existing Web sites—the normal online use of 
FrameMaker documents. They actually let you create and maintain 
entire Web sites in FrameMaker.

Nuts & bolts

The two Web site templates use a custom page size that forces you 
to keep your page depth shallow (to reduce the amount of scrolling 
a site visitor has to do).

Website.fm. This template contains several pages that make up a 
personal Web site. When you save this file as HTML, the format 
called DocStart forces FrameMaker to create a new HTML page at 
that paragraph. If you add pages to the template site, be sure to for-
mat the first paragraph with DocStart (enter no text in it—an 
anchored frame is OK). Note that the section heads are contained 
in anchored frames. FrameMaker converts anything in an anchored 
frame, including text, to a GIF or JPEG graphic during an HTML 
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Save. This lets you easily preserve the look and style of your text 
simply by placing it in an anchored frame.

The home page contains an invisible table (formatted with the 
Unruled Table format) that lets you mimic columns on an HTML 
page. We’ve organized the site’s links in this table. The first two col-
umns contain links to the other pages in the site. The third column 
contains sample links to external sites. With View > Text Symbols 
on, note the hypertext marker at the start of each item. To see the 
underlying code, double-click the marker (the first word becomes 
selected), and choose Special > Hypertext. You’ll see an entry such 
as “gotolink notes” that creates a link to the Personal Notes or some 
other named page in the template. In the third column an entry to 
an external site might read “message URL http://www.adobe.com”. 
The internal link uses the Jump to Named Destination hypertext 
command. The external link uses the Message Client command. 
The other pages in the site generally have two hypertext markers. 
One, near the top of the page, uses the Specify named Destination 
and an entry such as “newlink notes” to name the page. Each sec-
ondary page also has a link back to the home page.

Corpsite.fm. This template works just like the personal Web site 
template. DocStart forces HTML page breaks. The front page, how-
ever, uses a more complex navigation mechanism than the table of 
text links we used in the personal template: a client-side imagemap. 
Note how all the graphics and section names are placed in a large 
anchored frame on the first page of the template. With Borders and 
Text Symbols on, note the text frames covering each of the sections 
(About Our Company, products, etc.). You’ll also see a hypertext 
marker in each of the frames. These markers jump to the other 
named pages in the site using the same mechanism as in the per-
sonal site. When FrameMaker saves this template as HTML, the 
anchored frame becomes an imagemap with hotlinks to the other 
locations in the site.

Direct.fm. The Directory template lets you maintain a company
directory you can save as HTML and then easily incorporate int
company’s intranet. An administrative assistant, for example, w
no background in Web programming or HTML, can maintain th
directory in FrameMaker and periodically save it as HTML, pas
ing the HTML document on to the staff in charge of the intranet
Managing the source document in FrameMaker makes updatin
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easier, does not require knowledge of HTML, and, with 
FrameMaker 5.5 or later, lets you easily sort the employee list s
always remains in order. Three files appear in the directory whe
you save this file as HTML: direct.html, direct-1.gif, and direct.cs
The intranet manager should receive all three files. The direct.h
file contains the page itself. The direct-1.gif file is the anchored
frame (converted to a graphic) that forms the heading for the di
tory HTML page. The direct.css file is a special file used by brow
ers that recognize cascading style sheets (and so, it’s actually 
mandatory to include it).

Making it your own

M Always have Borders and Text Symbols turned on (View menu) when editing either of the Web 
site templates. Both documents rely heavily upon anchored frames, text frames, and hypertext 
markers whose accidental deletion could prevent the sites from working correctly when exported 
to HTML.

Besides the obvious step of adding your own content to the site 
templates, follow these instructions to create a functional Web site:

1 Create a new, empty folder for your Web site.

2 Choose File Save As, select HTML as the file format, change the 
file extension from .fm to .htm or .html, and save the file into 
the empty folder.

3 Open the folder and locate the file you just saved (for example, 
mysite.html). Delete it. There will be several other files with 
sequential numbers added to their name in the folder, as well.

4 Locate the file called mysite.1.html and rename it to index.html 
or index.htm—the default home page names expected by 
browsers and most Web servers. (The home page link on all the 
secondary pages in these sites is predefined and refers to 
“index.hmtl” so it’s essential that you rename the first sequen-
tially numbered HTML page to that name.)

5 Upload all the files in the folder to the directory on your Web 
server. Your Web site should now be accessible.

t It may seem strange to delete the initial file under whose name 
you saved to HTML. Here’s why you need to do it. The DocStart format 
has the option “Start New, Linked Web Page” option enabled in the 
HTML Setup dialog box. Normally, FrameMaker simulates a TOC in the 
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first file (mysite.html, for example) using the text found in paragraphs 
(usually headings on other pages) with this option enabled. The first 
file becomes the home page with links to the new pages created dur-
ing conversion to HTML. Unfortunately, this leaves you with little con-
trol over the appearance of the home page. Our technique trashes this 
first page (which is empty because our DocStart paragraphs have no 
text in them) and uses the first sequentially numbered HTML page 
(renamed index.html) as the home page.

If you change the headings on any of the pages, you might want to 
locate all the relevant hypertext markers and rename them accord-
ingly. See the FrameMaker Users Guide or online help for detailed 
instructions on creating hypertext links in HTML documents.

Classified ads (Classif.fm)

One of the most time-consuming typesetting jobs is formatting 
and organizing text for use in classified ads. This template makes it 
a snap to do just that.

Difficult
format, easy

solution

Classifieds rely on rules and section heads for organization. This 
template uses the Frame Above and Below settings to insert the 
rules automatically. There’s even a boilerplate display ad you can 
modify and use in the layout.
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Nuts & bolts

Use the ClassHead1 format for a main classified heading such as 
“Pets” and use ClassHead2 for subclassifications. Both formats 
switch automatically to Body when you press Return.

To enter a display ad, format a paragraph with the DisplayAdAn-
chor format and then copy and paste one of the samples found on 
the template’s body or reference page.

Making it your own

Use condensed fonts to cram as much copy into the columns as 
possible. Or make use of FrameMaker’s wonderful Stretch option 
in the Default Font property of the Paragraph Designer to con-
dense a favorite font by entering a percentage less than 100.

Note that all the template’s formats start with “Class” or “Display.” 
This lets you safely import these formats into another template and 
not have any of the format names collide. Thus, you can add a clas-
sified section to your own template. Be sure to also import Refer-
ence pages (to bring along the ruling lines).
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