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Important Notice
Frame Technology® Corporation (“Frame”) and its licensors retain all 
ownership rights to the FrameMaker® computer program and other 
computer programs offered by Frame® (hereinafter collectively 
called “Frame Software”) and their documentation. Use of Frame 
Software is governed by the license agreement accompanying your 
original media. The Frame Software source code is a confidential 
trade secret of Frame. You may not attempt to decipher, decompile, 
develop, or otherwise reverse engineer Frame Software, or 
knowingly allow others to do so. Information necessary to achieve 
the interoperability of the Frame Software with other programs may 
be available from Frame upon request. You may not develop 
passwords or codes or otherwise enable the Save feature of Frame 
Software. Frame Software and its documentation may not be 
sublicensed and may not be transferred without the prior written 
consent of Frame.

Only you and your employees and consultants who have agreed to 
the above restrictions may use Frame Software (with the Save 
feature enabled), and only on authorized equipment. 

Your right to copy Frame Software and this publication is limited by 
copyright law and your end user license agreement. Making copies, 
adaptations, or compilation works (except copies of Frame Software 
for archival purposes or as an essential step in the utilization of the 
program in conjunction with the equipment), without prior written 
authorization of Frame, is prohibited by law and constitutes a 
punishable violation of the law.

FRAME TECHNOLOGY CORPORATION PROVIDES THIS 
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, 
EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED 
TO THE IMPLIED WARRANTIES OR CONDITIONS OF 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR 
PURPOSE. IN NO EVENT SHALL FRAME BE LIABLE FOR ANY 
LOSS OF PROFITS, LOSS OF BUSINESS, LOSS OF USE OR 
DATA, INTERRUPTION OF BUSINESS, OR FOR INDIRECT, 
SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES OF 
ANY KIND, EVEN IF FRAME HAS BEEN ADVISED OF THE 
POSSIBILITY OF SUCH DAMAGES ARISING FROM ANY DEFECT 
OR ERROR IN THIS PUBLICATION OR IN THE FRAME 
SOFTWARE.

Frame may revise this publication from time to time without notice. 
Some states or jurisdictions do not allow disclaimer of express or 
implied warranties in certain transactions; therefore, this statement 
may not apply to you.

Copyright 1986–1995 Frame Technology Corporation. All rights 
reserved.

In the United States, Frame, the Frame logo, Frame Technology, 
FrameBuilder, FrameMaker, and FrameViewer are registered 
trademarks, and the Frame stylized mark, Frame Application 
Program Interface, Frame Developer’s Kit, Frame Development 
Environment, FrameConnections, FrameMaker International 
Dictionaries, FrameMaker+SGML, FrameMath, and FrameServer 
are trademarks, of Frame Technology Corporation.

The following are trademarks or registered trademarks of Frame 
Technology Corporation in countries outside of the United States: 
Frame, Frame Application Program Interface, Frame Developer’s Kit, 
Frame Development Environment, the Frame logo, Frame 
Technology, FrameBuilder, FrameConnections, FrameMaker, 
FrameMaker+SGML, FrameMaker International Dictionaries, 
FrameMath, FrameServer, and FrameViewer.

The following are copyrights of their respective companies or 
organizations:

Adobe Type Manager  1994 Adobe Systems, Inc. All rights 
reserved.

Display PostScript  1994 Adobe Systems, Inc. All rights reserved.

ImageStream Graphics Filters  1991-1993 ImageMark Software 
Labs, Inc. All rights reserved.

Milo  1988-1991 Ron Avitzur

PANTONE® Computer Video simulation used in Frame Software 
may not match PANTONE-identified solid color standards. Use 
current PANTONE Color Reference Manuals for accurate color. 
PANTONE Color Computer Graphics Pantone, Inc. 1986, 1988.

The spelling and thesaurus portions of Frame Software are based on 
THE PROXIMITY LINGUISTIC SYSTEM  1992 Proximity 
Technology Inc.; C.A. Stromberg AB; Espasa-Calpe; Hachette; IDE/
AS; Kruger; Lluis de Yzaguirre i Maura; Merriam-Webster Inc.; 
Munksgaard Int. Publishers Ltd.; Nathan; Text & Satz Datentechnik; 
Van Dale Lexicographie bv; William Collins Sons & Co. Ltd.; 
Zanichelli. All rights reserved.

The installer software used by the Windows version of Frame 
Software is based on the Microsoft Setup Toolkit 1992 Microsoft 
Corporation.

TypeScaler  1989 Sun Microsystems, Inc. All rights reserved.

The following are trademarks or registered trademarks of their 
respective companies or organizations:

Adobe, Adobe Type Manager, ATM, PostScript, SuperATM, 
Adobe Printer Driver / Adobe Systems Inc.

Apple, AppleLink, AppleScript, AppleTalk, Balloon Help, Finder, 
ImageWriter, LaserWriter, PowerBook, QuickDraw, QuickTime, 
TrueType, XTND System and Filters; Macintosh and Power 
Macintosh, used under license / Apple Computer, Inc.

ImageStream Graphics Filters / ImageMark Software Labs, Inc.

Milo / Ron Avitzur

Proximity, Linguibase / Proximity Technology Inc.

Sun Microsystems, Sun Workstation, TOPS, NeWS, NeWSprint, 
OpenWindows, TypeScaler, SunView, SunOS, NFS, Sun-3, Sun-4, 
Sun386i, SPARC, SPARCstation / Sun Microsystems, Inc.

All other brand or product names are trademarks or registered 
trademarks of their respective companies or organizations.

Any provision of Frame Software to the US Government is with 
“Restricted Rights” as follows: Use, duplication, or disclosure by the 
Government is subject to restrictions set forth in subparagraphs (a) 
through (d) of the Commercial Computer-Restricted Rights clause at 
FAR 52.227-19 when applicable, or in subparagraph (c)(1)(ii) of the 
Rights in Technical Data and Computer Software clause at DFARS 
252.227-7013, and in similar clauses in the NASA FAR Supplement. 
Any provision of Frame Software documentation to the US 
Government is with Limited Rights. The contractor/manufacturer is 
Frame Technology Corporation, 333 West San Carlos Street, 
San Jose, CA 95110.

US versions and some international versions are printed in the 
United States.
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1 Introduction 1
Frame® filters are programs that convert document and graphic files from one format to 
another. A document file contains information created with a word processor or publishing 
application; a graphic file contains a picture. 

About filters
There are two types of filters:

• Document filters convert document files that were created with other applications into 
Frame documents. The files may contain graphics. You convert document files by 
opening them with the Frame product Open command or importing them with the 
Import command.

Through the Save As command, the document filters also export Frame documents to 
other applications.

• Graphic filters import graphics created with other applications into Frame documents. 

Through the Windows Clipboard, the graphic filters also export Frame graphics to 
other applications in BMP or WMF format.

Filters are located in the directory where your Frame product is installed. You can choose 
whether to install filter files when you install a Frame product. If you did not install filters, 
you’ll need to run the Installer again. For more information about installing Frame products 
(including filters), see the installation manual for your Frame product.

Graphics filters use information in filter initialization files (.ini files). You can change 
settings in .ini files, as described in Chapter 8, “Customizing Graphics Filters.”

FrameMaker and FrameMaker+SGML support all filters described in this manual. 
FrameReader does not include document import or export filters. FrameViewer does not 
include export filters. 

Supported formats
You can convert documents and graphics in the formats listed in the following tables. Frame 
filters also allow you to export documents and graphics from Frame products to the 
Windows Clipboard, from which you can paste them into other applications. Two asterisks 
(**) indicate that a format can be exported (by copying) to the Windows Clipboard.
Using Frame Filters 1
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Document import filters

Document export filters

Graphic import filters

Format Applications/versions supported

ASCII Frame ASCII; Windows ANSI

Microsoft Word Macintosh® releases 3.0, 4.0, 5.0, 5.1, 6.0
Windows releases 1.x, 2.x, 6.0

Rich Text Format (RTF) Release 1.3

Ventura Publisher Releases 3.0, 4.0

WordPerfect DOS releases 4.2, 5.0, 5.1
Windows releases 5.0, 5.1, 6.0
For Macintosh releases, save in DOS or Windows 
format before converting

Format Applications/versions supported

ASCII** Frame ASCII; Windows ANSI

Rich Text Format (RTF) Release 1.2
Supports Windows Help RTF format

Format Applications/versions supported

AutoCAD Drawing Interchange 
Format (DXF)

AutoCAD releases 10, 11, 12

Bitmap (BMP)** Windows releases 3.0, 3.1

CompuServe Graphics 
Interchange Format (GIF)

Release 87a

Computer Graphics Metafile 
(CGM)

ANSI Standard (ISO8632, ANSI X3.12201986)

CorelDRAW (CDR) Release 3

Desktop Color Separation (DCS)

Digital Research Graphics 
Environment Manager (GEM)

Release 3

Encapsulated PostScript (EPSI, 
EPSF, EPS)

ASCII, TIFF, or WMF preview; releases 1.3–3.0

Hewlett-Packard Graphics 
Language (HPGL)

Release 2

Initial Graphics Exchange 
Specification (IGES)

CALS Classes I through IV, release 5.1

Macintosh QuickDraw (PICT) Releases 1, 2
Introduction 2
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Converting from unsupported formats
If you need to convert files that are in formats for which Frame products have no specific 
filter, you may be able to save the files to a format recognized by one of the filters (for 
example, RTF). You can then convert them from that format into Frame documents. Check 
whether your application can save files in a different format. This might be an option in the 
application’s Save command, or you might have to use a separate program to convert the 
file. An application’s conversion programs are often on a separate disk in the installation 
package. To find out where the conversion programs are, refer to your application’s 
reference manual.

MacPaint PackBits compression

Micrografx Drawing File Format 
(DRW, GRF)

Draw release 3.0, Designer release 3.1, Charisma 
release  2.1

Sun raster (rf) All releases 

Tag Image File Format (TIFF) Releases 5.0, 6.0

WordPerfect Graphics (WPG) Raster and vector; release 1

Windows Metafile (WMF)** Windows releases 3.0, 3.1

X Windows System bitmap (XWD) Release X11

Zsoft PC Paintbrush Bitmap 
(PCX)

1-bit, 4-bit, 8-bit, 24-bit

Format Applications/versions supported
Using Frame Filters 3
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2 Converting Files 2
This chapter describes basic conversion steps, how to prepare files for conversion, how to 
convert files, how to save converted documents, how graphics within document files are 
converted, and how specific file formats are converted.

Basic conversion steps
The basic conversion steps are as follows:

1. Prepare the file and graphics for conversion.

2. Convert the file into a Frame document by opening or importing.

3. Save the converted document.

4. Touch up the converted document.

Steps 1 through 3 are described in this chapter. Step 4 is described in the chapters 
describing specific file formats, later in this manual.

Preparing document files for conversion
The filters convert most features of the source files into equivalent Frame product features. 
For best results, follow these suggestions for preparing files before converting them:

• Avoid using tricks that force the application to simulate functions it does not naturally 
perform. For example, using negative indents to create side headings can make 
conversion more difficult.

• Use defined styles rather than local format overrides whenever possible.

• The filters assign the first column layout in the source file to all body pages in the 
converted document. It is easier to touch up converted documents that have more than 
one column layout if the most frequently used column layout is the first one in the 
source file.

Converting files
You can convert document and graphic files by either opening or importing them. Convert 
by opening when you want to convert an entire file. Convert by importing when you want to 
copy a file into an existing Frame product document.
Using Frame Filters 5
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The conversion process can take 5 to 10 times more memory or temporary disk storage 
than an original file requires. Before converting a file, make sure you have adequate 
memory and temporary disk space. If you run out of memory or disk space, you can divide 
the original file into smaller pieces (files), convert the files, and then paste them together in 
one Frame document.

Converting by opening
To convert a file by opening it:

1. Start the Frame product.

2. Choose Open from the File menu in the Frame product.

The Open Document dialog box appears. 

3. Select the file you want to open and click Open.

4. If the Unknown File Type dialog box appears, select the appropriate application or file 
format and click Convert.

It may take a few moments to convert a large file. When the conversion is complete, the 
Frame document opens.

If the file you convert uses unavailable fonts, Frame products substitute fonts during the 
conversion. If Show File Translation Errors is selected in the Preferences dialog box, 
Frame products display a console window (which may be minimized) listing the font 
substitutions. After the conversion is complete, you can click the icon to open the console 
window to see which fonts were used.

You can control which fonts substitute for unavailable fonts. For more information on 
customizing, see the online manual Customizing Frame Products.

Converting by importing

To convert a file by importing it:

1. Start the Frame product and open a document.

2. Place the insertion point where you want to position the imported document or 
graphic.

3. Choose Import>File from the File menu.

The Import File dialog box appears.

4. In the scroll list, select the name of the file you want to import. 

5. Select Import by Reference or Copy into Document, and click Import.

6. If the Unknown File Type dialog box appears, select the appropriate application or file 
format and click Convert.

The file is converted and imported into the Frame document. (For more information on 
import options, see your user’s manual.)

Graphic files are converted and copied into an anchored frame at the location of the 
insertion point in the Frame document. If you’re importing a bitmap, a dialog box appears 
so you can specify the bitmap’s scale.
Converting Files 6



H o w  g r a p h i c s  i n  d o c u m e n t  f i l e s  a r e  c o n v e r t e d2 Go To
Saving converted documents
After converting a file by opening it as a Frame document, you must save the Frame 
document using the Save As command on the File menu. To avoid overwriting the source 
file, be sure to enter a new name for the converted document.

You may need to touch up the converted document, either to restore lost formatting 
information or to apply formats from an existing Frame document. For details, see the 
chapters describing specific file formats, later in this manual.

How graphics in document files are converted
Graphics that are stored externally are converted only if they are in a supported format.

Resident graphics in a format other than WMF, such as drawings in the application’s native 
format or graphics imported by copying, are not converted.

Embedded graphics in OLE format usually contain a WMF image. If it is present, the WMF 
image is used during conversion. The OLE object itself is not converted.

For a list of graphic formats that Frame products support, see “Graphic import filters” on 
page 2.

If a source file references graphics that are in a format Frame products do not support, a 
message that the Frame product cannot import the graphics appears during the conversion. 
In this case, you should open the source file in the source application, save the graphics in 
WMF format (or another supported format), and then convert the file. Alternatively, if the 
source application is a Windows application, you can copy graphics from the source file and 
paste them into a Frame document.

Saving Frame documents in other formats
You can export documents from Frame products by saving them in any supported format. 

1. Open a Frame document.

2. Choose Save As from the File menu.

The Save Document dialog box appears. 

3. Specify where you want the document to be saved.

To avoid overwriting the source file, be sure to enter a new name for the document to 
be saved.

4. Choose a format from the Format pop-up menu.

5. Click Save.
Using Frame Filters 7
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Touching up documents
Frame filters ignore or alter some formatting details, so you might need to restore some 
formats after converting your files. This section contains general information about touching 
up documents after converting them. For more detailed information, see the chapters on 
specific formats, later in this manual.

Applying formats to a Frame document
After converting a file, you can format the document most easily by using formats from an 
existing Frame template. The names of the formats in the template catalogs, page layouts, 
and definitions should match the names of the formats in the converted document. 
Otherwise, applications that generate random format names might require editing in your 
converted documents. Follow these general steps for applying formats from templates:

1. If you used templates to format your original documents, convert those templates first to 
the Frame product. Otherwise, create new Frame templates with the page layouts, 
headings, and text formats you want.

2. Convert your documents.

3. In the converted documents, choose the Import>Formats command on the File menu to 
apply the formats from your templates. For more information, see your user’s manual.

Drop caps
Frame products convert drop cap characters to the default character format of the current 
paragraph. 

To achieve the drop cap character effect in Frame products:

1. Insert an anchored frame at the upper left of the paragraph, using the Run into 
Paragraph anchoring position.

2. Use the Text Line tool to create a large character within the anchored frame.

3. Press Esc m p to shrink-wrap the anchored frame around the character.

For information on creating and positioning anchored frames and adding text lines, see your 
user’s manual.

Tip: To apply an existing format to several converted files, create a book in the Frame 
product that includes all the converted files. Then use the Import>Formats command on the 
book File menu.
Converting Files 8
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Small text 
Some imported text might appear greeked (as a gray or colored bar) because it is in a small 
font size. This affects text only as it appears on the screen. 

To display the text:

1. Choose Preferences from the File menu.

2. Type the desired point size in the Greek Screen Text Smaller Than text box and click 
Set.

The text is now legible on the screen.

For information about displaying greeked text, see your user’s manual.

Tables
After converting a table, you resize columns by selecting them and dragging a selection 
handle. Frame products automatically wrap text in cells. Use the following features to edit 
a table. For more information about tables, see your user’s manual.

Tab stops
Even though Frame products support tables, there may be times when you want to use 
tabs. Frame product tab stops are absolute rather than relative. If the tab stops in the files 
you’re converting are relative, you may need to modify tab settings. 

Note: You can also zoom the document or select text lines and apply a character format 
with a larger font size. 

To change Use this feature

Tabular text to a table Convert to Table command on the Table menu

A table format Table Designer 

Paragraph formats in cells Paragraph Designer 

Page breaks for table rows Row Format command on the Table menu 

Ruling styles and cell shadings Custom Ruling & Shading command on the 
Table menu 

Cell alignment and cell margins Table Cells properties in the Paragraph 
Designer 

Rotation of text in cells Rotate command on the Graphics menu

Greeked text
Using Frame Filters 9
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When tab stops are relative, the insertion point moves to the next tab stop each time you 
press Tab. For example, the insertion point in the following illustration moves to the 
beginning of column 3 when you press the Tab key because the insertion point is already 
to the right of the first tab stop.

Frame product tab stops are absolute; that is, the n th tab on a line moves the insertion 
point to the n th stop. Because they are absolute, you must press the Tab key twice to move 
the insertion point to the beginning of column 3.

 

If your document has one tab stop per column, you might occasionally need to add tab 
characters with Frame products to ensure that the insertion point advances to the 
appropriate column. If your document has more tab stops than were needed in a table, you 
must either add tab stops in your Frame document or delete the extra tab characters in the 
converted text.

To change tab stops, drag the tab stops in the ruler. You can also double-click the tab stop 
you want to edit in the ruler to display the Edit Tab Stop dialog box. Redefine the tab stop 
position and alignment and then click Edit. For more information about changing tab stops, 
see your user’s manual. 

Left margin

First tab stop

Second tab stop

Tab symbol

Tab key pressed once

New position of 
insertion point

Tab key pressed twice

New position of 
insertion point
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The Microsoft Word Import filter converts files from Word for Macintosh 3.0, 4.0, 5.0, and 
6.0, and Word for Windows 1.0, 2.0, and 6.0.

If you need to convert a Frame document to Microsoft Word format, save it in RTF format, 
and then open it in Word. See Chapter 5, “RTF Filters.”

Touching up your documents
Your documents might lose some formatting information in the conversion from Word. After 
converting the file, you can touch up your document, either to restore lost formatting 
information or to apply formats from an existing Frame document. This section tells you how 
to format the document and re-create Word features that aren’t converted.

For additional information, see “Touching up documents” on page 8.

Borders
The filter converts only horizontal borders, which are positioned above or below a section 
of text. These are translated into lines in Frame Above and Frame Below reference frames. 
All line styles are supported. However, spacing between double-line borders is unsupported. 

Vertical borders and drop shadows are omitted. To re-create these types of borders, use 
the drawing tools on the Tools palette.

Character formatting
Superscript or subscript text is positioned correctly, but it is displayed in the same font size 
as the default body text. To reduce the font size of superscript or subscript text throughout 
the document, use the Document>Text Options command on the Format menu. To reduce 
the font size of selected superscript or subscript text, use the Font>Size command on the 
Format menu.

The Outline and Shadow character styles are translated, but they do not display or print on 
some workstations (the filter translates them to the default font). However, these styles will 
appear if the Frame product file is opened on a Macintosh. 

Captions
Word captions convert to regular paragraphs with the Word caption label as the paragraph 
format name. Use the Paragraph Designer to change formatting for all caption paragraphs 
with the same paragraph tag.
Using Frame Filters 11
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Color
The filter converts Word colors to Frame product colors. 

Graphics
You might have to make changes to the Frame document to make graphics appear exactly 
as they did in the Word document.

Graphic frames
In Word, a graphic is placed on the line containing the special character that refers to it. In 
Frame products, these graphics are placed in anchored graphic frames below the line that 
includes the anchor symbol. If several Word graphic characters occur on a single line, 
Frame products convert these to graphics that are centered and vertically stacked. This 
difference can change page appearance. 

If necessary, reposition anchored frames using the Anchored Frame command on the 
Special menu.

Graphics with runaround text
The filter does not convert runaround text. For graphics that are positioned directly on a 
page, select the graphic and choose Runaround Properties from the Graphics menu to 
specify how text should flow around the graphic. For graphics in an anchored frame, select 
the frame, choose Anchored Frame from the Special menu, and select Run into Paragraph 
as the anchoring position.

Graphics drawn in Word
The filter converts graphics drawn in Word to a single graphic object that can be displayed, 
repositioned, and resized in the Frame document. Individual objects within the graphic 
cannot be modified. 

Imported graphics
The filter can convert most imported graphics. See “Converting graphics” on page 17. 

Headers and footers
In Word, if a header or footer has more text than fits in the designated area, the page 
automatically adjusts to accommodate the text. This adjustment overrides the user-defined 
page margins. When the filter converts pages with this override, the headers and footers 
may not appear correctly. 

You may need to adjust the page layouts in the filtered document. All the text of a header 
or footer may not appear when the header or footer text column is too small or when 
Microsoft Word has automatically adjusted the page layouts.
Microsoft Word Import Filter 12
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Hidden text
The filter converts Word hidden text to conditional text in the Frame document. It gives 
hidden text the condition tag Hidden with the color red as the condition indicator. The hidden 
text is visible in the generated document. If you want to view or print the document without 
the hidden text, you must hide text with the Hidden condition tag using the Conditional Text 
command on the Special menu. 

Imported text files
The filter converts text files imported by reference to text imported by reference in the Frame 
document. The text file must reside in the same directory as the Word document. To change 
the properties of imported text, choose Text Inset Properties from the Edit menu. 

Multisection documents
The filter doesn’t fully convert the page layout in multisection documents. Page layout for 
additional sections is derived from that of the first section. You need to touch up documents 
where sections exist because the column flow changes between single and multiple 
columns or where headers and footers vary between sections.

There are two ways of working with separate sections. First, you can divide the original 
document into a separate document for each section (for example, a table of contents, a 
text document, and an index). This approach is the simplest. You must use this method if 
you want to specify a different numbering format for each section. 

A second method is to add master pages and create a new page layout for each additional 
section. Use this method when sections have different page layouts. For information about 
creating special page layouts, see your user’s manual.

Overflowing text frames
If text flows into an unconnected text frame, it may overflow at the end of the text frame 
after conversion. An overflow occurs when a text frame has more text than it can hold. If 
you see a solid black line at the bottom of a text frame when borders are turned on (with 
the Borders command), the text frame contains overflowing text. This text is only hidden 
from view; it is not deleted. For more information on overflows, see your user’s manual.

The black line 
shows that this text 
frame contains 
overflowing text.
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Paragraph spacing
Paragraphs might be spaced more closely after conversion to Frame documents. In Word, 
if you specify values for Space Before and Space After, Word adds the space before a 
paragraph to the space after the preceding paragraph. It then uses this combined value as 
the distance between paragraphs. Frame products determine spacing by comparing the 
Space Above and Space Below values, taking the larger of the two values as the space 
between paragraphs. As a result, in Frame products paragraph spacing may be closer than 
in Word.

To correct paragraph spacing, change the values in the Space area of the Basic properties 
in the Paragraph Designer. To correct spacing throughout the document, apply your change 
to the Paragraph Catalog and update all paragraphs with the tag in the Paragraph Designer.

Special characters
Frame products do not support all formats of Word’s current date and time variables. Word 
supports three formats for the current date and two formats for the current time. Frame 
products support a single variable that can contain either the current date, the current time, 
or both. If a header or footer line in a Word file contains both a current date and a current 
time variable, the filter creates a line that contains a double occurrence of a single date and 
time variable.

Correct the date and time variable formatting by changing the header or footer on the 
appropriate master page. To specify which current date and time variable option to insert, 
use the Variable command on the Special menu.

Symbols
The filter converts Word for Windows symbol characters by translating the font name, font 
size, and symbol code to the Frame font name, font size, and character code. Most 
commonly used symbol characters translate correctly, but some characters might not. 
Character mappings for the Zapf Dingbats font and fonts (such as Wingdings) that have no 
Frame product equivalent might also translate incorrectly. Correct any incorrectly converted 
characters in the Frame document. For a list of Frame characters, see the Quick Reference 
for your Frame product. 

Tables
When the Word import filter converts tables, rows with right or left margins that differ from 
the preceding rows break into separate tables. You might need to touch up column 
alignment using the Resize Columns command on the Table menu, or change cell margins 
by resetting the Default Cell Margins values in the Table Designer.

If a table cell has one border definition and its adjacent neighbor has another, the filter 
assigns both cells a single border definition. This can create differences in the converted 
document.
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Table of authorities and citations
Citations convert to markers with the type Author. To generate a table of authorities from a 
converted document, choose Generate/Book from the File menu and create a list of markers 
that includes markers with the type Author.

Word styles
Word styles convert to Frame paragraph formats. You might need to modify these formats 
using the Paragraph>Designer command on the Format menu.

Unsupported Word features
Some Word features are not converted and must be re-created in a Frame product. The 
following is a list of unsupported Word features and the Frame product commands to 
re-create them. For detailed instructions, see your user’s manual.

Unsupported 
Word feature

To re-create it in Frame products

Absolute position of 
objects and frames

Create an anchored or unanchored graphic frame and re-create 
the contents. Frame product options for positioning anchored 
frames differ from Word options.

Annotations and 
revisions

The filter converts annotations and revisions to regular text.

Custom footnote 
separators

Use the Reference Pages command on the View menu to display 
a reference page, and then create or change the footnote 
separator.

Date and time 
variables used 
together in a header 
or footer

Use the Variable command on the Special menu to insert a date 
variable in the running text for headers and footers.

Embedded objects The filter does not convert embedded objects. Re-create the object 
within the Frame product. For example, you can re-create an 
embedded equation using the Equations palette.

Endnotes The filter converts endnotes to footnotes in the Frame document. 

Forms The filter converts forms to regular text.

Frames Use the Anchored Frame command on the Special menu to insert 
a frame. Use the Tools palette to re-create any graphics. The filter 
converts any text that was in a frame and places it before the 
paragraph that contained the frame. Copy this text to text frames 
or text lines in the Frame product anchored frame.
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Headers and footers 
after the first set in a 
multisection 
document

Display master pages, and then choose the Add Master Page 
command on the Special menu to add a new master page. Choose 
Import>Formats on the File menu to use header and footer formats 
from another document or template. Or create headers and footers 
on the new master page; then use the Variable command on the 
Special menu to create page numbers in the running text for the 
headers and footers. 

Line numbering Frame products do not display line numbers in a document. You 
can use the Go To Page command on the View menu to display a 
line by specifying its number. 

Mail merge 
documents

The filter converts the main document only.

Math objects, math 
formula marks

Use the Equations palette to create math objects.

Negative indentation 
of paragraphs

Use indent settings in the Basic properties of the Paragraph 
Designer to define paragraph indents. Paragraphs extending 
beyond text frame margins on either side of the page are 
unsupported.

Newspaper-style 
columns

Use the Customize Layout>Customize Text Frame command to 
create multiple columns in a text frame. To use multiple columns 
throughout a document, convert the text frames on the master 
pages to multiple-column text frames.

Page number variable 
used in body text

Use the Variable command on the Special menu to insert a Page 
Count variable.

Paragraph borders: 
boxes, vertical lines, 
and drop shadows

For horizontal lines, use the Above ¶ and Below ¶ pop-up menus 
on the Advanced properties of the Paragraph Designer. For boxes, 
vertical lines, and drop shadows, create an anchored frame or 
single-cell table. For an anchored frame, use the Tools palette to 
draw boxes or vertical lines around a text frame inside the 
anchored frame. For a single-cell table, use the Custom Ruling & 
Shading command on the Tools menu to draw borders and 
shading.

Position operations on 
paragraphs

Use Alignment and Indent settings in the Basic properties of the 
Paragraph Designer to define paragraph positioning.

Table formats The filter does not convert Word Table AutoFormat formats to 
Frame table formats. Use the Table Designer to create table 
formats and assign them to converted tables.

Table of information 
from a database or 
Excel spreadsheet

The filter converts the table as regular text and does not maintain 
the link between the database or spreadsheet. 

Unsupported 
Word feature

To re-create it in Frame products
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Converting graphics
The filter converts imported graphics that were copied into the Word document. If a graphic 
was imported by reference, the filter will maintain the link and display the graphic only if its 
format is one that the Frame product supports. Also, the graphic file must reside in the same 
directory as the Word document. If the graphic uses an unsupported format, you can filter 
it separately and then import it into the generated Frame document.

The filter stores Macintosh PICT and Windows WMF graphics directly in the Frame 
document. When you open the document on a platform that cannot display a WMF or PICT 
graphic, the Frame product generates a FrameVector equivalent. FrameVector is the 
internal format for representing graphic objects in Frame products.

Word for Windows graphics
Because FrameVector format supports fewer fill patterns than WMF, you might see slight 
differences in shading and coloring of graphics. Also, FrameVector format does not support 
WMF features for clipping, setting the background color, setting the aspect ratio of fonts for 
a specific device, and justifying text.

Tables of contents Use the Import>Formats command on the File menu to copy a 
reference page from a TOC template and Generate/Book 
command on the File menu to generate the table of contents.

Tabs using the bar 
style tab window to 
create leader 
characters for tabs

Use the Basic properties of the Paragraph Designer.

Underlining by word 
and dotted underline

Use the Character Designer to create a underline format. To 
underline selected text, use the Style>Underline command on the 
Format menu. Dotted underline is unsupported.

Vertical alignment of 
text on a page

For a single page, adjust the position and size of the text frame on 
the page. To format several pages, display master pages, and then 
choose the Add Master Page command on the Special menu to 
add a new master page. Adjust the position and size of the text 
frame on the new master page. Display each body page you want 
to reformat and choose Pages>Master Page Usage to apply the 
page layout from the new master page. 

Unsupported 
Word feature

To re-create it in Frame products
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4 WordPerfect Import Filter 4
The WordPerfect Import filter converts documents from the following releases of 
WordPerfect:

• Windows releases 5.0, 5.1, 6.0

• DOS releases 4.2, 5.0, 5.1

For Macintosh releases, save in DOS or Windows format before converting.

Touching up your documents
When you’re ready to work with a converted WordPerfect document in a Frame product, 
you’ll notice differences between the WordPerfect document and the Frame product version. 
This section tells you how to format the document and re-create WordPerfect features that 
aren’t converted.

Bookmarks and hypertext
Bookmarks convert to hypertext markers in the Frame document. Hyperlink buttons convert 
to anchored graphic frames that contain a hypertext marker that reproduces the hyperlink. 
Hypertext links that execute macros convert to Frame hypertext markers that display an 
alert containing the macro name.

Counter boxes
The filter translates the numbers associated with counter boxes to regular text. To preserve 
paragraph numbers, use outline styles in the WordPerfect document. See “Outline styles” 
on page 21

Cross-references
Page cross-references convert to cross-references to a page number. All other WordPerfect 
cross-reference types convert to cross-references to a paragraph autonumber. If a 
WordPerfect cross-reference refers to more than one source in the document, the filter 
converts only the first source. Question marks in the converted document indicate cross-
references that need updating. To update cross-references in a Frame product, choose 
Cross-Reference from the Special menu.
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Footnotes and endnotes
WordPerfect endnotes convert to Frame footnotes. WordPerfect allows different definitions 
for footnote and endnote properties, and Frame products allow only one footnote definition. 
The filter uses the first WordPerfect footnote and endnote properties to assign Frame 
footnote properties. To change the Frame footnote style, use the Document>Footnote 
Properties command on the Format menu. 

Graphics
The filter converts most WordPerfect graphics. It converts horizontal lines to anchored 
frames that contain a single line. It ignores all vertical lines in the WordPerfect document, 
so you might need to create these in the Frame product. Also, it converts graphics box 
numbering to an autonumbered Frame paragraph. You might need to correct the font of the 
autonumber, and you might need to adjust the numbering after adding or removing graphics 
in a Frame product. Graphics boxes of page anchor type convert to floating Frame product 
anchored frames. For more information, see “Unsupported WordPerfect features” on 
page 24.

There is no limit to the number of graphic objects (such as lines, polylines, and ellipses) 
that the filter can handle. However, there is a limit to how many graphic objects Frame 
products can handle. The Frame product might run out of memory when there are many 
graphic objects. If this happens, break the graphics into separate files and filter them 
separately. 

If a graphic is imported by reference, it must reside in the same directory as the 
WordPerfect document. 

Hidden text
Hidden text converts to conditional text with the condition tag Hidden and the color red as 
the condition indicator. Hidden text is visible in the converted document. If you want to view 
or print the document without the hidden text, you must hide text with the Hidden condition 
tag using the Conditional Text command on the Special menu.

Imported text files
The filter converts text files imported by reference to text imported by reference in the Frame 
document. The text file must reside in the same directory as the WordPerfect document. To 
change the properties of imported text, choose Text Inset Properties from the Edit menu. 

Indents
In WordPerfect, any line in a paragraph can be indented and a paragraph can have multiple 
indents. The indent position depends where the type-in point is when the paragraph is 
indented. Because the filter does not have this information, it uses the tab positions to 
determine indent positions. 
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Indexes
The filter converts WordPerfect index entries to Frame index markers. It converts all 
WordPerfect index styles to a simple index style, with page numbers following entries. 
It does not support the WordPerfect concordance file feature. 

In the Frame document, use the Marker command on the Special menu to insert additional 
index markers in the text, and the Generate/Book command on the File menu to generate 
the index.

Kerning (Advanced Positioning)
WordPerfect and Frame products handle pair kerning differently. The filter attempts to force 
kerned text to appear the same in Frame documents by inserting forced line breaks. This 
process might introduce blank lines for text that was shifted to the left. To adjust pair kerning 
in the Frame document, use the Style setting in the Default Font properties of the Paragraph 
Designer or the Style setting in the Character Designer.

Master documents
A WordPerfect master document converts to a single Frame document. 

Outline styles

When an outline style is specified in a WordPerfect document, WordPerfect automatically 
creates a hierarchy of indented paragraphs for the outline. The filter converts this hierarchy 
into separate paragraph formats and assigns sequential tags to them. For example, a 
WordPerfect outline style named Table that contains four levels becomes four Frame 
paragraph formats called a0Table, a1Table, a2Table, and a3Table. These formats are 
stored in the Paragraph Catalog, even if the outline style was never used in the WordPerfect 
document.

Outline-style autonumbers
In WordPerfect, you can create outline-style autonumbers that are hierarchically nested. 
These might have style tags such as a1Document, a2Document, and so on.

If outline-style autonumbers are turned on in the Style Catalog, but you did not consistently 
apply them, then the Frame product Paragraph Catalog might list levels of tag names that 
were not in the original WordPerfect file.

Page margins
WordPerfect allows arbitrary changes of page margins, and Frame products do not. All 
WordPerfect pages with less than 1-inch margins are converted to Frame pages with 1-inch 
margins. 
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Paragraph autonumbering
Frame products allow autonumbering at the beginning and end of paragraphs, and 
WordPerfect allows autonumbering anywhere in a paragraph. WordPerfect paragraphs with 
autonumbering at the beginning or the end convert to equivalent Frame paragraphs. 
WordPerfect paragraphs that have autonumbering in the middle normally convert as two 
Frame paragraphs. When 40 characters or fewer or only tabs precede the autonumber, the 
paragraph converts to a single Frame paragraph with the preceding characters and the 
autonumber as the Autonumber Format. 

All WordPerfect bullet styles convert to a round bullet character in Frame documents.

Paragraph languages
The WordPerfect language property is converted to the Frame paragraph language. 
WordPerfect allows the language to change anywhere in a document, while Frame products 
assign the language as a paragraph property. The filter uses the first language assigned to 
a paragraph as the paragraph language, and displays a warning if the language changes 
in the WordPerfect paragraph. 

Frame products do not support all WordPerfect languages. The filter converts the 
WordPerfect language English-Australia to the Frame product language International 
English. It converts the following WordPerfect languages to no language and issues a 
warning: Afrikaans, Croatian, Czechoslovakian, Greek, Hungarian, Icelandic, Russian, 
Slovak, and Ukrainian.

Paragraph styles
You can format paragraphs in WordPerfect using either the Styles feature or local overrides. 
The filter converts WordPerfect Styles to Frame paragraph formats, stores them in the 
Paragraph Catalog, and assigns them the same name they had in WordPerfect. The filter 
converts paragraph styles created with local overrides, but does not store them in the 
Paragraph Catalog; it identifies them with the tag WPNoTag in the document window 
status bar. 

Tab leaders
WordPerfect and Frame products handle fonts for tab leaders differently. WordPerfect uses 
the font assigned to characters before the leader, and Frame products use the font assigned 
to characters after the leader. If there are font changes, the leaders might not appear 
correctly in the converted document. To correct this problem. add an extra space after the 
tab and before the font changes. 
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Table of authorities
The short-form entries for a table of authorities convert to Frame markers of type Author. 
To generate a table of authorities from a converted document, choose Generate/Book from 
the File menu and create a list of markers that includes markers with the type Author. The 
full-form entries for a table of authorities do not convert. 

Table cell ruling
In WordPerfect, table cells can have the default ruling style (the style assigned to the table 
as a whole) and a custom ruling color. In Frame products, the color is associated with the 
ruling style. The filter ignores custom ruling colors for table cells that use the WordPerfect 
default ruling style. It uses both color and line style to convert custom ruling styles. 

Templates
WordPerfect templates convert as regular documents. You may need to manually touch up 
the filtered documents.

Text colors
The filter converts WordPerfect text colors to Frame colors. Because WordPerfect colors 
are represented by red, green, and blue values and not by names, the filter generates 
Frame product color names. These names have the prefix WPGColor and a number. For 
example, WPGColor0, WPGColor1, and so on.

WordPerfect provides two ways to change the text color. You can set the text color or 
change the text to redline. In both cases, the filter converts the color applied to the text. 
When both text color and redline are applied, the filter ignores the text color information and 
uses the redline information. 

Word and letter spacing
The filter converts custom word spacing in the WordPerfect document to its equivalent in 
the Frame product. Adjust word spacing settings in the Advanced properties of the 
Paragraph Designer. 

The filter ignores WordPerfect letter spacing options. To control letter spacing, use the Allow 
Automatic Letter Spacing setting in the Advanced properties of the Paragraph Designer.
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Unsupported WordPerfect features
Some WordPerfect features are not converted and must be re-created in the Frame product. 
Following is a list of unsupported WordPerfect features and the Frame commands to 
re-create them. For detailed instructions, see your user’s manual.

Unsupported 
WordPerfect 
feature

To re-create it in a Frame product

Advance text Use the Anchored Frame command on the Special menu to create 
an anchored graphic frame. Use the Tools palette to add graphics, 
text frames, and text lines.

Baseline placement Use the Master Pages command on the View menu to display a 
master page; there you can resize and reposition the text frame.

Bindings Use the Master Pages command on the View menu to display a 
master page; there you can resize and reposition the text frame so 
it has the correct margins for printing. Frame products do not 
support different margins for viewing and printing.

Block protection To specify that a paragraph does not break between columns, 
specify a large number in the Widow/Orphan lines text box in the 
Pagination properties of the Paragraph Designer.

Centering top to 
bottom

Use the Master Pages command on the View menu to display a 
master page; there you can resize and reposition the text frame.

Conditional end of 
page

Use the Keep With setting in the Pagination Properties of the 
Paragraph Designer to specify text that should not be broken.

Date codes Use the Variable command on the Special menu to insert a date 
variable.

Equations Use the Equations palette to re-create the equation. 

Floating cells The filter converts floating cells (single-cell tables) to regular text. 
To reformat as a single-cell table, create the table and copy the text 
into it. 

Forced odd/even 
pages

Use the Page Layout>Page Size command on the Format menu.

Graphics box style Use the Anchored Frame command on the Special menu to 
reposition the frame. 

Labels for mail merge Labels do not convert.

Line numbering Frame products do not display line numbers in a document. You 
can use the Go To Page command on the View menu to display a 
line by specifying its number. 

Linking and 
embedding 

The filter does not convert information from other applications that 
was included in the WordPerfect document by linking or 
embedding.

Mail merge The filter does not convert mail merge documents.
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Master documents Use the Generate/Book command on the File menu. In the 
Generate dialog box, click New Multifile Book; then add documents 
using the Set Up File and Add File commands on the book’s File 
menu.

Page borders Use the Master Pages command on the View menu to display a 
master page; there you can draw borders.

Rotated and mirrored 
graphics boxes

Graphics boxes are converted to Frame product anchored frames 
that are not rotated or mirrored. Use the Rotate command on the 
Graphics menu to rotate an anchored frame. Use the Group 
command on the Graphics menu to group all of the objects in the 
frame and then use the Flip command to mirror them. 

Runaround text The filter converts WordPerfect text wrap-around graphics boxes 
to Frame product anchored frames below the current paragraph. 
For graphics that are positioned directly on a page, select the 
graphic and choose Runaround Properties from the Graphics 
menu to specify how text should flow around the graphic. For an 
anchored frame, select the frame, choose Anchored Frame from 
the Special menu, and select Run into Paragraph as the anchoring 
position.

Spreadsheets The filter does not convert spreadsheets, and there is no 
equivalent feature in Frame products.

Table names The filter does not convert WordPerfect table names, and there is 
no equivalent feature in Frame products.

Table formulas The filter does not convert table formulas, and there is no 
equivalent feature in Frame products. 

Tables of contents Use the Generate/Book command on the File menu to generate 
the table of contents document, and then use the Import>Formats 
command on the File menu to copy a reference page formats from 
a table-of-contents template.

Tables of authorities Use the Marker command on the Special menu to insert markers 
in the text, and the Generate/Book command on the File menu to 
generate the table.

Text art The filter does not convert WordPerfect text art, and there is no 
equivalent feature in Frame products.

Text columns Use the Import>Formats command on the File menu to apply the 
column layouts of the master pages from another document or 
template, or the Master Pages command on the View menu to 
display a master page, where you can re-create your own column 
layouts.

Unsupported 
WordPerfect 
feature

To re-create it in a Frame product
Using Frame Filters 25



T o u c h i n g  u p  y o u r  d o c u m e n t s4 Go To
Watermarks Use the Master Pages command on the View menu to display the 
master pages and draw background graphics.

Widow and orphan 
Control

Use the Widow/Orphan Lines setting in Pagination properties of 
the Paragraph Designer.

Word and letter 
spacing

Use the Word Spacing setting in Advanced properties of the 
Paragraph Designer.

Unsupported 
WordPerfect 
feature

To re-create it in a Frame product
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The RTF Import filter converts documents from the Microsoft Rich Text Format (RTF). RTF 
is an interchange format used by many word processing applications. The filter supports 
RTF as described in version 1.3 of the RTF Specification. The RTF Export filter translates 
Frame documents into RTF version 1.2 files. 

RTF Import filter

Touching up your documents
Your documents might lose some formatting information in the RTF-to-Frame conversion. 
After converting the file, you can touch up your document, either to restore lost formatting 
information or to apply formats from an existing Frame document. This section tells you how 
to format the document and re-create RTF features that aren’t converted.

Colors
The filter converts RTF RGB colors to Frame product CMYK colors. RTF colors that match 
the default Frame product colors map directly to those colors. Other RTF colors convert as 
Frame product colors with the name rRedValue_gGreenValue_bBlueValue, where 
RedValue, GreenValue, and BlueValue are the levels for the red, green, and blue 
components of the RTF color (for example, r70_g20_b80). You can change these names 
to more descriptive names in the Frame document. 

Custom footnote separators
The filter converts custom footnote separators. In multicolumn documents with separators 
that contain text, line breaks within that text might be different in the Frame document. To 
correct the line breaks, display reference pages and adjust the size of the separator text 
column within the Footnote reference frame. For more information about footnote 
separators, see your user’s manual. 
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Fields
The filter supports the following fields. The contents of all other field types are converted to 
regular text.

Graphics
You might have to make changes to the Frame document to make graphics appear exactly 
as they did in the RTF document.

The filter does not convert graphics drawn using a word processor (RTF drawing objects).

The filter converts imported Macintosh PICT and Windows Metafile (WMF) graphics. 
Imported graphics in any other format are omitted from the converted document.

Hidden text
The RTF Import filter converts RTF hidden text to conditional text in the Frame product 
document. It gives hidden text the condition tag Hidden and uses the strikethrough style 
and the color red as condition indicators. The hidden text is visible in the generated 
document. If you want to view or print the document without the hidden text, you must hide 
text with the Hidden condition tag using the Conditional Text command on the Special 
menu. 

Multisection documents
Because there is no equivalent in Frame documents, the filter does not convert sections 
and section page layout changes. It applies the page layout and page numbering style of 
the first section to the whole document. Pages are numbered continuously. In documents 
where sections have different page layouts or numbering styles, you need to touch up the 
converted Frame to duplicate the style changes.

There are two ways of working with separate sections. First, you can divide the original 
document into a separate document for each section (for example, a table of contents, a 
text document, and an index). This approach is the simplest. You must use this method if 
you want to specify a different numbering format for each section. Add the documents to a 
book to automatically generate the table of contents and index.

This field type Converts to

date Current Date (Long) or Current Date (Short) variable.

filename Filename (Short) variable.

gotobutton Hypertext marker. If a single paragraph contains several such fields and 
no text formatting changes, the Frame product may only recognize the 
first field. If the field is in a graphic, the Frame hypertext marker will be 
in the paragraph containing the graphic.

numpages Page Count variable.

page Current Page # variable.

symbol The corresponding special character.

time Current Date (Short) variable.
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A second method is to add master pages and create a new page layout for each additional 
section. Use this method when sections have different page layouts. For information about 
creating special page layouts, see your user’s manual.

Paragraph spacing
Paragraphs might be spaced more closely after conversion to Frame documents. In RTF, 
if you specify values for space before and space after, RTF adds the space before a 
paragraph to the space after the preceding paragraph. It then uses this combined value as 
the distance between paragraphs. Frame products determine spacing by comparing the 
space before and space after values, taking the larger of the two values as the space 
between paragraphs. 

To correct paragraph spacing, change the values in the Space area of Basic properties in 
the Paragraph Designer. To correct spacing throughout the document, apply your change 
to the Paragraph Catalog and update all paragraphs with the tag in the Paragraph Designer.

Styles
Styles convert to Frame product paragraph formats. The filter converts most style 
properties. You can use the Paragraph Designer to modify paragraph formats in the Frame 
document.

Unsupported RTF features
The following is a list of unsupported RTF features and the Frame product commands you 
can use to re-create them. For detailed instructions, see your user’s manual.

Unsupported RTF 
feature

To re-create it in Frame products

Absolute position of 
objects and frames

Create an anchored or unanchored graphic frame and re-create 
the contents. Frame product options for positioning anchored 
frames differ from RTF options.

Annotations and 
revisions

The filter converts annotations and revisions to regular text.

Bidirectional writing 
support

There is no equivalent in Frame products.

Callouts Use the Text Line tool to create the callout text and the Line or 
Polyline tool to create leader lines.

Column balancing To balance all columns in a text flow, choose Page 
Layout>Column Layout from the Format menu and turn on 
Balance Columns in the Column Layout dialog box. To balance 
columns in a selected text frame, choose Customize 
Layout>Customize Text Frame from the Format menu and turn on 
Balance Columns in the Customize Text Frame dialog box. 

Document summary 
information

There is no equivalent in Frame products.
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Drop caps Insert an anchored frame at the upper left of the paragraph, using 
the Run into Paragraph anchoring position. Then use the Text Line 
tool to create a large character within the frame, and shrinkwrap 
the frame around the character.

Embedded objects The filter does not convert embedded objects. Re-create the object 
with the Frame product. For example, you can re-create an 
embedded equation using the Equations palette.

Endnotes The filter converts endnotes to footnotes in the Frame document. 

File linking Use the Generate/Book command on the File menu to generate a 
new book. Use commands in the book File menu to add files to the 
book in the appropriate order and set their properties.

Forms There is no equivalent in Frame products.

Fractional character 
widths (for printing)

There is no equivalent in Frame products.

Frames The filter converts only graphic frames containing PICT or WMF 
graphics. It omits any other graphic frames. Use the Anchored 
Frame command on the Special menu to insert an anchored frame 
or the Graphic Frame tool to create an unanchored graphic frame. 
Use the Tools palette to re-create any graphics. Use the Import 
command to import a graphic into the graphic frame.

Headers and footers 
after the first set in a 
multisection 
document

Display master pages, and then choose the Add Master Page 
command on the Special menu to add a new master page. Choose 
Import>Formats on the File menu to use header and footer formats 
from another document or template. Or create headers and footers 
on the new master page; then use the Variable command on the 
Special menu to create page numbers in the running text for the 
headers and footers. 

Line numbering Frame products do not display line numbers in a document. You 
can use the Go To Page command on the View menu to display a 
line by specifying its number. 

Negative indentation 
of paragraphs

Use indent settings in the Basic properties of the Paragraph 
Designer to define paragraph indents. Paragraphs extending 
beyond text frame margins on either side of the page are 
unsupported.

Paragraph borders: 
boxes, vertical lines, 
and drop shadows

The filter converts only horizontal lines. For boxes, vertical lines, 
and drop shadows, create an anchored frame or single-cell table. 
For an anchored frame, use the Tools palette to draw boxes or 
vertical lines around a text frame inside the anchored frame. For a 
single-cell table, use the Custom Ruling & Shading command on 
the Table menu to draw borders and shading. 

Unsupported RTF 
feature

To re-create it in Frame products
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RTF Export filter
The RTF Export filter converts Frame documents to RTF format. The documents can then 
be converted to other formats, including Microsoft Word and Windows Help formats. 

Converting documents to RTF
Some features in Frame products have equivalents in other word processing applications 
and some do not. The following are limitations in translating Frame documents into 
Microsoft Word format. The results might be different when you use the RTF file with 
another word processing application. 

Document layout
The right master page determines the page size and margins. Text flows are exported in 
the page order they appear in the document. If a page contains multiple text flows, the filter 
first exports the flow that starts in the largest text frame, followed by the smaller text frames. 

Publish and 
Subscribe

Not converted. Use the Import>File command on the File menu to 
import document or graphic files in formats that Frame products 
support.

Referenced files Use the Import>File command on the File menu to import 
document or graphic files in formats that Frame products support.

Revision marks Use the Character Designer or the Document>Change Bars 
command on the Format menu to apply change bars. 

Runaround text For graphics that are positioned directly on a page, select the 
graphic and choose Runaround Properties from the Graphics 
menu to specify how text should flow around the graphic. For an 
anchored frame, select the frame, choose Anchored Frame from 
the Special menu, and select Run into Paragraph as the anchoring 
position. 

Side-by-side 
paragraphs

To reformat specific paragraphs as side-by-side paragraphs, use 
the Insert Table command on the Table menu to create a table with 
two columns and one row. Move the side-by-side paragraphs into 
the table cells. To reformat an entire text flow to use multiple 
columns or side heads, use the Page Layout>Column Layout 
command on the Format menu. To reformat a specific text frame 
to use multiple columns or side heads, use the Customize 
Layout>Customize Text Frame command on the Format menu.

Subdocuments There is no equivalent in Frame products.

Tables of contents Use the Import>Formats command on the File menu to copy a 
reference page from a TOC template and the Generate/Book 
command on the File menu to generate the table of contents.

Vertical alignment There is no equivalent in Frame products.

Unsupported RTF 
feature

To re-create it in Frame products
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If a text flow starts on a page that does not use the right master page, the filter starts a new 
section on a new page. The filter computes the correct number of columns and column gap 
for each section based on the text frames on the master page and the global document 
margins.

Multiple columns that vary in width convert to columns of equal width.

Word does not support mixed portrait and landscape pages. The filter exports the text on 
rotated pages, but all the pages in the Word document use the same orientation.

Headers and footers
Rotated headers and footers convert as unrotated. Running headers and footers are not 
supported.

Paragraph Catalog
A Frame Paragraph Catalog becomes a Word style sheet. The filter also defines styles for 
paragraph tags used in the document that are not present in the Paragraph Catalog. Base 
styles are not supported.

Frame Above and Frame Below paragraph format settings
If a paragraph includes a separator frame above or below it, the separator frame converts 
to a line above or below the paragraph.

Paragraph spacing
The spacing between paragraphs may not translate as expected. Between two paragraphs, 
Frame products uses the larger of the Space Above and Space Below settings. Word adds 
the two numbers. For example, consider a heading paragraph with a 12-point Space Below 
setting followed by a body paragraph with a 6-point Space Above setting. In Frame 
products, the spacing between the paragraphs is 12 points. In Word, the spacing is 18 
points.

Tabs
Because Frame products and Word use tabs differently, tab locations may format 
unexpectedly, especially if your paragraph formats contain extra, unused tab markers.

The three Tab leaders supported by Word (dotted line, dashed line, and solid line) are 
converted. Other tab leaders are ignored.

Character formats
Pair kerning does not convert to RTF.

Cross-references
Cross references convert using the last resolved values in the Frame document.

Variables
Date and current page number variables convert to glossary entries. Other variables convert 
to text.
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Graphics
Graphics that have Macintosh PICT or Windows WMF facets in the Object Properties dialog 
box convert when they are located inside anchored graphic frames. All other graphic 
formats, unanchored graphics, and graphics drawn with the Frame drawing tools are 
ignored. Rotated images convert as unrotated.

Tables
Ruling lines convert to the closest Word equivalent. Rotated cells convert as unrotated. Cell 
shading, custom cell margins, and maximum row height settings do not convert. Table titles 
appear in either the top row or the bottom row of the table. The title straddles all columns 
of the table and has no borders, so that it resembles a title instead of a cell.

Footnotes
If there is a footnote separator in the Frame file, it converts to a single-line separator in 
Word. The Footnote paragraph format in the Frame file converts to the footnote text style 
in the Word style sheet. 

Index markers
Frame index markers convert to Word index entries. Multiple sorts, special sorts, and font 
changes are ignored.

Converting documents to Windows Help RTF format
The Microsoft Windows Help Compiler (provided with most Windows software development 
tools) compiles RTF files into Help files that you can view with the standard Windows Help 
viewer. You can use a Frame product and the RTF Export filter to create RTF files from 
which to generate Windows Help files. 

There are two steps to creating Windows Help files with Frame products. First, you must 
create the source documents. See “Creating Help source documents,” next. Then, save the 
document as RTF.

Creating Help source documents
A Windows Help source document uses page breaks, footnote control codes, and character 
formats to specify Help topics, topic characteristics, and links between topics. For a 
complete description of the Help file format, see the Help Compiler documentation.

The following table shows the RTF features used to create Help files and the corresponding 
Frame product features.

RTF feature Purpose in Help file To create it in Frame products

# footnote Specifies context string of topic Create custom footnote numbers. 

$ footnote Specifies title of topic Create custom footnote numbers. 

K footnote Specifies keywords for topic Create custom footnote numbers.

+ footnote Specifies browse sequence 
number for topic

Create custom footnote numbers. 

* footnote Specifies build tag for topic Create custom footnote numbers. 
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Setting up custom footnotes
To set up custom footnotes for Windows Help in a Frame document:

1. Choose Document>Footnote Properties from the Format menu. 

2. Type the custom footnote numbers, in the order you want to use them, in the Custom 
text box.

For example: *,#,$,K,+.

3. Choose Start Over on Each Page.

4. Click Set.

To enter footnotes on a topic page, choose Footnote from the Special menu. The Frame 
product automatically numbers footnotes in the sequence you specified. 

Hidden text Specifies the context string for 
the topic to display when the 
user clicks text that immediately 
precedes it

Choose Conditional Text from the 
Special menu, and apply any condition 
tag to the text. The filter converts 
conditional text to RTF hidden text.

Page break Separates topics Use the Page Break command on the 
Special menu.

Strikethrough or 
double-underlined 
text

Indicates text the user can click 
to jump to another topic

Use the Strikethrough or Double 
Underline style.

Underlined text Indicates text the user can click 
to display another topic in a pop-
up window

Use Underline style.

Important: If you are using build tags in your Help system, the build tag footnote (*) must 
appear first on each page.

RTF feature Purpose in Help file To create it in Frame products
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You can convert any chapter created with Ventura Publisher 3.0 or 4.0, provided the files 
don’t include data or objects created by:

• Ventura Scan

• Ventura ColorPro

• Ventura Separator

• Ventura PhotoTouch

• Ventura DataBase Publisher add-on products

When you convert a Ventura chapter file, the .STY, .VGR, and .CAP files associated with 
the chapter file are converted automatically.

If the message “Unknown error opening file” appears, the filter is unable to locate a support 
file (for example, a style sheet) for the chapter. Make sure the pathnames in the Ventura 
Publisher chapter file correspond to the correct location of each support file.

The filter opens Ventura chapter files only. It will not open publication files. If you have a 
publication file, do the following:

1. Convert each chapter in the publication to a Ventura chapter file.

2. Convert each Ventura chapter file to a Frame document.

3. Create a Frame product book file and add the converted chapters to the book.

See your user’s manual for more information about creating book files.

Preparing files for conversion
You may have to modify Ventura chapter files before you can convert them. The filter does 
not automatically convert text stored in other word processing formats that are referenced 
by a Ventura chapter. 

To convert native word processing files to text:

1. Start Ventura Publisher and open the chapter file.

2. Select the various text flows that contain referenced text from other word processing 
files.

3. Choose the File Type/Rename command from the Ventura Frame menu.

4. Select ASCII as the Text Format and click OK.

5. Save the chapter file.
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Preparing graphic files
Ventura chapter files often include references to external graphic files. These files remain 
in their native format. To appear in a converted Frame document, these graphic files must 
be in a format that Frame products recognize (for example, EPS or PCX). 

Before you convert a chapter file:

1. Convert all external graphic files to a format that Frame products recognize.

2. Start Ventura Publisher and open the chapter file.

3. For each graphic file you converted, make sure the chapter file refers to the new 
version of the file, not the old one.

4. Save the chapter file.

If you don’t convert graphic files to a format recognized by Frame products, gray boxes 
appear in place of the graphics when you open the converted document in Frame products. 

Checking for anchored frames
The Ventura Publisher filter converts both anchored and unanchored frames. However, 
because of differences in font metrics, paragraph spacing, and so on, unanchored frames 
may appear in slightly different locations after the document is converted. Also, Frame 
products do not support graphics with automatic text wraparound. After you convert a 
document, you may have text hidden under an unanchored graphic frame. Whenever 
possible, you should anchor frames before you convert the document. 

Unanchored named frames
The filter will not convert unreferenced named frames in a Ventura Publisher file. Before 
you filter a Ventura Publisher chapter file, make sure to either anchor these frames or 
remove the name of the frame.

International characters
The filter supports chapter files that use the international character set. However, you may 
have problems if the paragraph tag names in the Ventura style sheet use lowercase 
international characters. Before you convert the document, change lowercase international 
characters in the style sheets to uppercase characters. Otherwise, the paragraph tag name 
could be lost, and the paragraph may change to an incorrect format.
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Touching up converted documents
After converting the file, you can touch up your document, either to restore lost formatting 
information or to apply formats from an existing Frame document. The following is 
information on how to format the document and re-create Ventura features that aren’t 
converted.

Anchored frames
The filter does not convert multiple references to the same anchored frame. The first 
occurrence of the frame is converted, but additional occurrences are not. After you convert 
the document, you can copy the anchored frame and paste it in the locations where it was 
referenced.

To help you see where a frame is missing, the filter inserts a Comment marker and the 
message <Duplicate Anchor - anchor name>, where anchor name is the name 
of the referenced anchor. You can use the Find/Change command to search for the marker 
in the converted document. For information on finding markers, see your user’s manual.

Publication files
Ventura publication files are like Frame book files. They contain pointers to a series of 
chapter files. The filter converts only chapter files; it doesn’t convert publication files to book 
files. If you have a publication file, use the filter to convert each chapter file in the publication 
separately. Then create a Frame book file and add the converted chapters to the book. For 
more information on creating book files, see your user’s manual.

Ruling
Ventura Publisher lets you place ruling around paragraphs and text frames. Boxes around 
tables are converted. Other ruling conversions are as follows.

Ruling above or below a paragraph
Ruling above or below a paragraph is converted. Frame products store ruling in a reference 
frame. For more information on reference frames, see your user’s manual.

Ruling around a paragraph
The top and bottom ruling in a box is converted to ruling above and below the paragraph. 
The ruling on the left and right sides of the box is not converted. 

To re-create a box in a Frame product:

1. Use the Insert Table command to create a table that has one row and one column.

2. Copy the paragraph text into the table cell.

3. Use Ruling properties in the Table Designer to add ruling to the outside of the table.

For more information on tables and table ruling, see your user’s manual.
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Ruling around text frames
Ruling around text frames is converted. In Frame products, ruling is drawn around text 
frames with the Polyline tool. For more information about polylines, see your user’s manual.

Sequence numbering
Sequence numbering for chapter, figure, and table references is not converted. You’ll need 
to re-create these numbers using Frame cross-references. For information, see your user’s 
manual. To help you see where sequence numbers are missing, the filter inserts the 
following text:

The filter also inserts a Comment marker. You can use the Find/Change command to 
search for this marker in the converted document. For information on finding markers, see 
your user’s manual.

Tables

Custom ruling and shading
The filter does not convert custom ruling or shading for table cells. You need to use the 
Custom Ruling & Shading command to create the same effect in the converted document. 
For more information, see your user’s manual. The filter does convert ruling that applies to 
an entire table (for example, a box around the table).

Straddles
The filter does not convert straddles over columns or rows in tables. You need to use the 
Straddle command on the Table menu to re-create the straddles in the converted document. 
To help you locate cells that no longer straddle, the filter inserts a plus symbol (+) if the cell 

Type of sequence number Text

Chapter <C#>

Figure <F#>

Table <T#>
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should be combined with the cell on the left. The filter inserts a caret symbol (^) if the cell 
should be combined with the cell above. 

Table width
In Ventura Publisher, not all tables have explicit widths. For example, some tables vary in 
width depending on the size of the frame that contains the table. For tables without explicit 
widths, the filter automatically sets the width to 1 inch per column. For a table with just a 
few columns, the converted table may be narrower than the original table. For a table with 
a large number of columns, the converted table may be much wider than the original table. 
To adjust the width of the table in a Frame product, select the table and choose Resize 
Columns from the Table menu. For more information, see your user’s manual.

Tabs

Ventura Publisher documents have both enabled and disabled tab stops. The filter converts 
enabled tab stops and removes disabled tab stops. The filter deletes tab stops that are not 
greater than the previous tab stops. For example, in a Ventura Publisher chapter that has 
three numbered tab stops—tab stop 1 at 1 inch, tab stop 2 at 3 inches, and tab stop 3 at 
2 inches—only tab stops 1 and 2 appear in the converted document.

Tab stops are not numbered in Frame products. The tab sequence for a paragraph starts 
at the left margin and continues sequentially to the right. 

Table after 
straddles are fixed 
in the converted 
document

Indicates cell 
should be 
combined with 
cell on left

Indicates cell 
should be 
combined with 
cell above
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If the headers and footers do not line up properly in a converted document, you may need 
to update the tab stops in the header and footer paragraphs on the converted document’s 
master pages. 

For more information on adding and deleting tab stops, and information about master 
pages, see your user’s manual.

Tag names
Frame products are case-sensitive. Paragraph tag names from the Ventura Publisher style 
sheet are converted to initial caps in Frame products. Here are some examples:

If you don’t like the new name, you can change it. For information on how to change the 
name of a paragraph format, see your user’s manual.

Uppercase international characters, such as È, are not converted to lowercase. For 
example, the style sheet name BULLÈT is converted to BullÈt instead of Bullèt. The filter 
does not support lowercase international characters in the style sheet.

Unanchored frames
Because of differences in font metrics, paragraph spacing, and so on, unanchored frames 
may appear in slightly different locations after a document is converted. Whenever possible, 
you should anchor frames before you convert the document. After you convert the 
document, check for any unanchored graphic frames that are not in their correct locations.

Repeated frames
If a repeated frame appears on both the left and right master pages of the Ventura Publisher 
chapter file, only the frame contents on the right master page are converted. The frame on 
the left master page is converted but not the contents of the frame. The filter inserts the 
message <Repeat From Right>. To correct this problem, you can copy the contents of 
the frame on the right master page and paste it in the empty frame on the left master page.

Ventura Publisher name Frame product name

LargeFigure Largefigure

LARGEFIGURE Largefigure

largeFIGURE Largefigure

Large figure Large Figure

LARGE FIGURE Large Figure

LARGE_FIGURE Large_Figure
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Frame products include two filters for importing PICT graphics:

• The QuickDraw PICT filter converts a PICT graphic to a single graphic object in a 
Frame document. You cannot edit any of the individual elements that comprise the 
graphic.

• The QuickDraw PICT to MIF filter converts PICT graphics to their equivalents in a 
Frame document. If the original PICT file contains editable graphics (such as lines or 
rectangles), the converted graphics are also editable. Bitmaps (which cannot be edited 
in the PICT file) convert to bitmaps that cannot be edited in the Frame document.

When you open or import a PICT file, Frame products normally use the QuickDraw PICT 
filter to convert it. To use the QuickDraw PICT to MIF filter, you must select it in the Convert 
From list in the Unknown File Type dialog box. If the Unknown File Type dialog box does 
not appear when you open or import a PICT file, change the value of the 
ForceFileTypeChoices setting in your Frame product initialization file to On. For 
example:

ForceFileTypeChoices=On

This setting instructs the product to display the Unknown File Type dialog box each time 
you open or import a file. For more information on editing Frame product initialization files, 
see the online manual Customizing Frame Products. 

The rest of this chapter describes how the QuickDraw PICT to MIF filter converts objects 
within the PICT graphic.

Differences in converted graphics
The filter converts PICT graphics to MIF as accurately as possible. However, because PICT 
and Frame products don’t describe all graphic objects the same way, you might notice some 
differences in the converted pictures.

Colors
Colors might appear slightly different. The filter chooses the Frame product color that most 
closely matches the PICT color.

Fill and pen patterns
The filter supports hatch patterns (horizontal stripes, vertical stripes, right-slanted stripes, 
left-slanted stripes, and diagonal cross-hatching), a fill pattern of None, and gray shades. 
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The filter examines the PICT patterns for a match to the Frame patterns. If it finds no close 
match, it substitutes a gray shade.

If a PICT object has two different pen and fill colors, the fill color will be used for the entire 
MIF object.

PICT PixPats can be used as paint to fill objects. A PixPat can be a combination of a fill 
pattern and a color, or a color bitmap. PixPat color bitmaps contain patterns. The filter 
doesn’t support the bitmap, but uses the pattern. When the PixPat is a fill pattern and color, 
the color is mapped to one of the Frame colors, and the pattern is matched to a Frame 
pattern or calculated to a gray scale.

Pen widths
In PICT, the pen has both a width and a height. Frame products do not have separate 
values for pen width and height. Consequently, thick lines might look slightly different in 
Frame products.

Rounded rectangles
In PICT, the corners of rounded rectangles can be ovals. The filter changes the corners of 
rounded rectangles so the corners are circles.

PICT rounded rectangle Frame product rounded rectangle
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Superimposed objects
The filter separates pen and fill patterns when it converts PICT objects. Consequently, a 
single object in a PICT picture can appear as several superimposed objects when you 
import the converted picture into a Frame document.

To manipulate the converted picture in a Frame product, use the Group command on the 
Graphics menu to group the superimposed objects into a single object. 

Text
All text converts to Frame text lines. The filter preserves the starting location of text in the 
picture. However, the converted picture might use a different font family or a slightly different 
font size. Also, character spacing might be somewhat different.

Customizing the font conversion
When you convert a PICT graphic, the import filter uses the file pictfont.cfg to match 
fonts used in the PICT file with the names of Frame fonts. The pictfont.cfg file is 
stored in the filters subdirectory of the Frame product installation directory. The default 
font values in pictfont.cfg are as follows.

PICT font number 
and name

Converts to Frame font

0 Helvetica Helvetica

3 Geneva Helvetica

4 Monaco Courier

21 Helvetica Helvetica

22 Courier Courier

23 Symbol Symbol

All others Times

This appears as a 
single rectangle in a 
PICT picture.

The converted picture consists of 
two objects superimposed to look 
like one.
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You can change these font conversions by editing the pictfont.cfg file. Use a text 
editor, such as Notepad, to edit the file. (You can also use a Frame product, but if you do, 
remember to save the file as Text Only.)

Each line of the file pictfont.cfg contains a PICT font number and the name of the 
Frame font it corresponds to. For example:

3 "Helvetica"
4 "Courier"

To map characters to different values, add specific character descriptions, such as:

3   "Helvetica"
      \x0d   \x20              # convert carriage returns to spaces
      \xa1   "Symbol"   \xb0   # degree sign
      \xbd   "Symbol"   \x57   # omega sign

In this example, the first line maps PICT font 3 to Helvetica in Frame products. The 
additional lines show character substitutions. The character codes are designated by \x, 
followed by two hexadecimal digits that represent the character. The first hex code denotes 
the PICT font character; the second denotes the Helvetica character. For example, the 
second line maps carriage returns (\x0d) in PICT font 3 to spaces (\x20) in Helvetica. 

The third and fourth lines map the degree and omega signs in PICT font 3 to the Symbol 
font in Frame products because there are no equivalent characters for these signs in 
Helvetica. When you declare a font change, such as these lines do, enclose the font in 
double quotation marks. 

If a font uses the same character map as one already defined, rather than repeat the 
character map, you can refer to the map already defined by typing:

SameAs #

where # is the number of the PICT font that already has the character definition. For 
example:

22   Courier
     SameAs 3

These lines apply the character maps for Helvetica (PICT font 3 in the previous example) 
to the Courier font in Frame products.

When you map characters, it helps to add comment lines explaining the translation. 
Comments are denoted with the number sign (#); the filter ignores all characters from the 
#  to the end of the line.
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This chapter contains information about graphic filter initialization files (.ini files), which 
you can edit to customize the behavior of some of the graphic filters.

About graphic filter Initialization files
Some Frame graphic filters use graphic filter initialization files, which contain default settings 
and filter-specific settings for items such as profile definition, font mapping, and color 
mapping. You can change some of the settings in the initialization files to customize a filter’s 
behavior.

Graphic filter initialization files are located in the directory where your Frame product is 
installed and they have the filename extension .ini.

Initialization file structure
An .ini file contains a header section and profile sections. Each profile section contains 
a group of related settings. Sections and settings have the following format:

[section_name]
setting_name=value

The [section_name] statement is the name of a section. The enclosing brackets ([ ]) 
are required, and the left bracket must be in the leftmost column on the screen.

The setting_name=value statement defines the value of each setting. A setting_name 
can be any combination of uppercase or lowercase letters and digits, and it must be 
followed immediately by an equal sign (=). The value of the setting can be an integer, a 
Boolean value, a string, or a string in quotation marks, depending on the setting. There are 
multiple settings in most sections.

To enable a Boolean setting, set the value to True, Yes, On, or 1. To disable a Boolean 
setting, set the value to False, No, Off, or 0. Certain Boolean settings are limited to 
numerics or certain text.

You can include comments in initialization files. Begin each line of a comment with a 
semicolon (;).

This manual lists .ini settings alphabetically, but settings do not necessarily appear 
alphabetically in a specific .ini file. To change a setting, you need to search for it in the 
appropriate section.
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Reading the [FILTER_NAME] section
The [FILTER_NAME] section is always the first block in an initialization file. All settings in 
the [FILTER_NAME] section are required. If you modify or delete one of these settings, the 
filter will not work properly. There are no specific default values for these settings; values 
are assigned based on individual filter requirements.

Section or setting name Description

[FILTER_NAME] Specifies the internal name for this filter DLL. 

Example: 
[IM_CGM]

~Default Mode=string Specifies the name of the profile to use if the ~Mode section 
is deleted. The default varies from filter to filter; usually it is 
Standard Options.

Example: 
~Default Mode=Standard Options

~Header=string Specifies the text used as the caption on the setup dialog 
box (if available) for editing this .ini file. The default varies 
from filter to filter; usually it is Standard Options.

Example: 
~Header=CGM Import Filter Setup

~Mode=string Specifies the current profile. The default varies from filter to 
filter; usually it is Standard Options.

Example:
~Mode=Standard Options

Profile=
FILTER_NAME.mode

There may be up to 32 profiles for the filter. Each profile has 
a setting in this block and a corresponding section that 
defines the specific settings for the profile.
Profile specifies the name of the profile; mode is the 
driver mode for the profile. The first character of the profile 
name must be an asterisk (*) if the profile is to be editable 
in the setup dialog box.

Noneditable example:
Standard Options=IM_CGM.0

Editable example:
*ImageMark - Binary=IM_CGM.16
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Reading the [Profile] section
The number of [Profile] sections in an initialization file may vary. Each [Profile] 
section contains settings that are used when the profile is selected as the current ~Mode. 
The [Profile] section can contain the following settings, but may also contain additional 
settings that are defined in the individual filter’s documentation.

Section or setting name Description

ColorTableSource=
string

Determines which source is used to set the color table. If set 
to FILE, the filter will use the color table contained in the file 
to determine indexed color values. If set to PROFILE, the 
filter will use the color table information included in this 
profile section. Default is FILE.

Example:
ColorTableSource=FILE

DefaultFileSpec=
path-searchstring

This is an optional field that is not used by the filter. 
However, CreateSetup() returns this value so that the 
application can use the information with the search string to 
read or write files in the specified directory.

Example:
DefaultFileSpec=c:\ims\*.pcx

Driver=
FILTER_NAME.mode

The mode indicates the subtype of files this profile supports. 
Not all filters support multiple subtypes. In all cases, the 
filter selects the appropriate subtype if ~Mode=Standard 
Options.

Example:
Driver=IR_BMP.1

Color[Index]=
(rval, gval, bval),"Name"

There may be up to 256 color-mapping entries in the 
[Profile] section. Index is a three-digit number 
between 000 and 255. The first entry must be 000 and each 
succeeding entry must be numbered consecutively (for 
example, 001, 002, and so on). The color values (rval, 
gval, and bval) correspond to red, green and blue 
intensities and must be in the range of 0 to 255. "Name" can 
be any name for the color, with a maximum length of 14 
characters.

Examples:

Color[000]=(128,128,128), "Gray"

Color[001]=(0,0,0), "Black"

Color[002]=(0,0,128), "Dark Red"
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Guidelines for editing initialization files
• Make backup copies of .ini files before making any changes so that you can restore 

the original file if necessary. Change only the settings described in this document. 
Changes made to other settings could cause a filter to fail.

• To change settings in an .ini file, use a text editor to open and edit the file. If you 
use your Frame product to edit the file, be sure to save the file in Text Only format. 

• Do not save .ini files in Frame Normal format or in any other word processor format.

• After changing an .ini file, you need to restart the Frame product to activate the 
new settings.

Graphics filters that you can customize
The following sections contain descriptions of the graphic filters that have .ini files you 
can edit. In the descriptions, common .ini settings are those that can appear in any .ini 
file and special .ini settings are those that appear only in that filter’s .ini file.

Font[Index]="Fontname",
"Description"

There may be up to 32 font-mapping entries in the 
[Profile] section. Index is a three-digit number 
between 000 and 032. The first entry must be 000 and each 
succeeding entry must be numbered consecutively (for 
example, 001, 002, and so on). "Fontname" is the name for 
the font used in files of the particular format, or a null string 
if the format only uses indices. "Description" is a 
Windows-compatible font description of the form 
Family:TypefaceAttributes. The maximum length 
for "Fontname" and "Description" is 62 characters.

Examples:

Font[001]="Sans Serif 
Bold","Swiss:Helvetica Bold"

Font[002]="","Roman:Times Italic"

Section or setting name Description
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AutoCAD Drawing Interchange Format (DXF)

Computer Graphics Metafile format (CGM)

Description Import filter for Autodesk AutoCAD vector file format.

Release identifier DXF release 12.0.

Coordinate system Real values with origin (0,0) at the bottom left corner.

Scaling mode Abstract.

.ini file IMDXF9.INI
The default option uses 256-color mapping. You can select 
profiles for 8-color or 16-color modes.

Common .ini settings [IM_DXF]
Color[Index]
ColorTableSource
Font[Index]
See “Reading the [Profile] section” on page 47.

Special .ini settings None.

Notes Only one viewport is imported from multiple-viewport DXF files. 
The filter sets the marker type to plus.

Description Import filter for hybrid file format (vector and raster) used by 
many popular graphic software products.

Release identifier CGM release 1.

Coordinate system Integer or real values.

Scaling mode Abstract or metric with scale factor.

.ini file IMCGM9.INI

Common .ini settings [IM_CGM]
Color[Index]
ColorTableSource
Font[Index]
See “Reading the [Profile] section” on page 47.

Special .ini settings None.

Notes Generalized Drawing Primitive, Escape, and Application Data 
are supported in ImageMark mode only. Some CGM profile files 
have no background color encoded into the file. The filter 
defaults to (170, 170, 170) Gray. You can override this in 
the IMCGM9.ini file with the Color[0 0 0] setting. For 
example, Color[0 0 0]=(0, 0, 0) sets background to 
black.
Using Frame Filters 49



G r a p h i c s  f i l t e r s  t h a t  y o u  c a n  c u s t o m i z e8 Go To
CorelDRAW format (CDR)

Digital Research Graphics Environment Manager format (GEM)

Description Import filter for CorelDRAW hybrid file format (vector and 
raster).

Release identifier CDR release 3.0.

Coordinate system Positive integers with origin (0,0) at the center of the page.

Scaling mode Metric (1200 dpi).

.ini file IMCDR9.INI

Common .ini settings None.

Special .ini settings None.

Notes Rotated rounded rectangles are emulated using Circular Arc 
Center. Extruded object groups, pattern sizing, and perspective 
editing are not fully supported. The following are not supported: 
text gradient fills, fully justified text, skewing text that is filled to 
a path, and OLE objects.

Description Import filter for Digital Research vector file format.

Release identifier GEM release 3.0.

Coordinate system Integers with origin (0,0) at the bottom left or top left corner.

Scaling mode Metric or abstract.

.ini file IMGEM9.INI

Common .ini settings [IM_GEM]
Color[Index]
ColorTableSource
Font[Index]
See “Reading the [Profile] section” on page 47.

Special .ini settings None.
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Hewlett-Packard Graphics Language format (HPGL)

Description Import filter for Hewlett-Packard plotter vector file format.

Release identifier HPGL/2.

Coordinate system Integers or real values with origin (0,0) at the bottom left corner.

Scaling mode Metric.

.ini file IMHGL9.INI

Common .ini settings [IM_HGL]
Color[Index]
ColorTableSource
Font[Index]
See “Reading the [Profile] section” on page 47.

Special .ini settings You must be using the standard .ini file to use special settings. 
Plotter model number (for default viewport size) is:
~Mode=PLOTTER MODE OPTION

Default is Standard Options. With different plotter mode 
options, the page size can be changed so you can import HPGL 
files that do not contain the Page Size command. The plotter mode 
and the corresponding page sizes are shown below. 

Standard Options (0, 0) to (12000, 9000)
HP7090 (–333, –100) to (10703, 7987)
HP7440/70 (0, 0) to (10300, 7650)
HP7475 (0, 0) to (10365, 7962)
HP7510/50A (0, 0) to (16344, 10896)
HP7570A (–10576, –7556) to (10576, 7556)
HP7580/85/86 (–3238, –4988) to (3238, 4988)
HP7595/96 (–4948, –3198) to (4948, 3198)
PRESCAN Finds an approximate bounding box by 

prescanning the file.

Notes Polyline encoding, Color Table commands, and User-defined 
characters are not supported. A Scale command maps all objects 
affected by it to the viewpoint. Image extent considers only the 
Scale command, not the individual objects affected by it. 
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Initial Graphics Exchange Specification format (IGES)

Macintosh QuickDraw format (PICT)

Description Import filter for IGES files.

Release identifier Release 5.1.

Coordinate system Real values with origin (0,0) at the bottom left corner.

Scaling mode Metric.

.ini file IMIGS9.INI

Common .ini settings None.

Special .ini settings None.

Notes Parametric spline surfaces, ruled surfaces, rational B-spline 
surfaces, finite elements, dimensioning, and solid entities are 
unsupported.

Description Import filter for hybrid file format (vector and raster) used by 
Apple Macintosh products.

Release identifier PICT releases 1.0 and 2.0.

Coordinate system Integers with origin (0,0) at top left corner.

Scaling mode Metric or variable dpi.

.ini file IMPCT9.INI

Common .ini settings [IM_PICT]
Color[Index]
ColorTableSource
Font[Index]
See “Reading the [Profile] section” on page 47.

Special .ini settings None.

Notes Pen size in a PICT file has height and width. The filter considers 
the larger of these two values to be the pen size. Regions are 
not fully supported. Line patterns, comments, bits and bits 
packed regions, clip regions, and highlight mode are not 
supported. Region transparency mode is ignored. Dithered 
pattern types use black as the auxiliary color.
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Micrografx Drawing format (DRW)

Description Import filter for Micrografx hybrid file format (vector and raster).

Release identifier DRW release 2.0.
Symbol release 4.0.

Coordinate system Positive integers with origin (0,0) at top left corner.

Scaling mode Metric or variable dpi.

.ini file IMDRW9.INI

Common .ini settings [IM_DRW]
Color[Index]
ColorTableSource
Font[Index]
See “Reading the [Profile] section” on page 47.

Special .ini settings Image Extent=Extent
Determines the how much of the document to convert. The 
default is First Page. Options are:

First Page The extent interpreted is based on the 
metric size of the first page of the 
document.

Entire Document The extent interpreted is based on the 
entire document (all pages).

Last View The extent interpreted is based on the 
view used when the document was 
saved in the source application

Notes File is prescanned to build a 256-element color table. Primitives 
in invisible layers are not supported. Rotated rectangles are 
emulated with polygons. Rotated rounded rectangles are 
emulated with elliptical arcs in a figure. Labeled lines are 
emulated with a line and a text string. Invisible lines are not 
supported. Release 1 files and winding fills are not supported.
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WordPerfect Graphic format (WPG)

Description Import filter for WordPerfect hybrid file format (vector and 
raster).

Release identifier WPG release 1.0.

Coordinate system Positive integers with origin (0,0) at bottom left corner.

Scaling mode Metric (1200 dpi).

.ini file IMWPG9.INI

Common .ini settings [IM_WPG]
Color[Index]
ColorTableSource
Font[Index]
See “Reading the [Profile] section” on page 47.

Special .ini settings None.

Notes WPG does not differentiate between Edge attributes and Line 
attributes. WPG files can contain several word processor text 
commands such as those that set justification and margins. 
These are not converted. All patterns are translated as bitmap 
patterns. Rotated bitmaps and text on a path are not supported. 
Shadowed objects are drawn as two distinct objects.
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